Questions & Answers

My StudioLive Mixer (classic or AI) will not connect with my PC Firewire 800 port

0 votes
265 views
asked Aug 18, 2015 in Ai Mixers by AlexTinsley (773,230 points)
Just as the question says, I can't get my StudioLive Mixer to connect with my PC Firewire 800 port.

1 Answer

0 votes
answered Aug 18, 2015 by AlexTinsley (773,230 points)
 
Best answer

With some Windows 7, 8 (8.1) or 10 PC computers, or computers running Windows 7, 8 or 10 Bootcamp on a Mac,
There could be an issue where the firewire card driver has been set to receive "automatic updates" to the "best"
driver Windows can provide for the card.  In the situation of Audio Devices like our StudioLive mixers and 
FireStudio Project and Mobile devices, this drive might not always work.

When looking at your firewire card driver, you can see inside of your Device Manager that the card has what is
called the "Unibrain driver / OHCI Compatible Board."  This driver is a specialty designed driver for cameras
and different periphrial devices (more inforamtion can be found on their website:  http://www.unibrain.com/

How to change the Unibrain Driver on your Windows System

1.  Power off your PreSonus FireStudio interface or StudioLive mixer. 

2.  Find your FireWire (IEEE 1394) controller in Device Manager (go to Start > Control Panel > System > Device Manager).

3.  Open the IEEE 1394 Bus Host Controllers group with the "Unibrain Driver."

4.  Right-click on your FireWire controller and choose "Update driver Software..."

5.  Use the "Browse my computer..." option.

6.  Choose the "Let me Pick from a List" option.

6.  If you are on a Windows 7 system, it is suggested that you would want to us the "Legacy" option depicted.
information on why you would want to choose this option can be found here.
If you are using a Windows 8, 8.1 or 10 machine, you can use the native "OHCI Compliant Host Controller."

You should have successfully updated your driver.  Check for functionality and if you need further assistance,
please Contact Technical Support.

...