Questions & Answers

My blackstar Id Core amp is recognised and installed on my computer, but will not show up Studio one 3 audio devices

0 votes
3,558 views
asked Jan 3, 2017 in Studio One 3 by danielhughes7 (130 points)
So I purchased a blackstar Id core amp and downloaded studio one 3. My computer has installed the id cores drivers and recognises it fine allowing me to transfer patches to the amp etc. When I go on to studio one, the amp or id core isn't showing up under audio devices and its saying it is unable to record along with the message,

Failed to open Digital Audio Interface (Id:core Amplifier)

Please make sure that the sample rates of your recording and playback devices match.

 

I'am of the understanding that whilst I'am recording with the guitar, the sound should play back through my laptop speakers ?

If anybody can shed any light on this it would be much appreciated.

Thankyou.

1 Answer

+2 votes
answered Jan 3, 2017 by brianmeisner1 (182,440 points)
 
Best answer

If you are on a Windows machine, you will want to install a free program called ASIO4all on your system for use as an audio driver with your Blackstar amp.  You can download ASIO4all from the following link:

http://www.asio4all.com/

Once installed, you can open Studio One and go to Studio One>Options>Audio Setup and set ASIO4all as your audio device.  Once you have set ASIO4all as your audio device in Studio One, you will see a small icon of a play button in your startup tray (next to the clock in the Windows status bar).  If you double-click this icon, you can choose the devices on your system that you would like to be communicating with Studio One via ASIO4all.  Here is a screenshot:

 

...