Questions & Answers

How do I get rid of unwanted delay when recording?

0 votes
4,381 views
asked Jan 20, 2017 in Studio One 3 by ethanbagley (150 points)
I had configured my set up 2 weeks ago, so recording and playback were in sync. I didn't have to worry about any delay. Now when recording I get an initial playback in my headphones, then half a second later it finally gets tracked and plays back again, rather more quietly. I am using an Epiphone Les Paul Guitar in good condition, through a new USB 2x2 AudioBox. I'm using Studio One x64 on my Windows PC. Any help will be very appreciated. Thanks in advance.

2 Answers

+2 votes
answered Jul 9, 2018 by cp20 (180 points)
edited Jul 9, 2018 by cp20
I have similar setup to you although with win10 and audiobox presonus usb96.  And I had the same problem, here's the fix:

1) For others reading, make sure you download that "universal control" for windows--it is separate from studio one and recognized the presonus hardware when you plug it into USB.  You'll be in windows configuration h*** trying to get any levels on tracks otherwise.

2) The Fix:   In studio one, click on the "Studio One" pulldown on top and choose "Options".  Now make sure you are on the "Audio Setup" (picture of a speaker).  Then on Audio Device, change it from "Windows Audio" to "Audiobox" (it should have a pulldown picture of your audiobox when you click on the device to change it).  I did not have to fiddle with the block size.

Why it happened:  When you open studio one without the audiobox plugged in, it will probably revert to "Windows Audio" again. This seems to be the case for me.
asked Feb 4, 2021 in Studio One 3 by kennethdavis14 (130 points) Thank you.
...