Questions & Answers

Where can I download FaderPort Installation file for PC Windows 10 64 bit?

0 votes
asked Apr 9, 2017 in FaderPort Classic by timbarden (190 points)
Brand New FaderPort Purchase as of April 2, 2017.   Cannot locate the installation file for Windows 10 64-bit which I find frustrating.  Am I missing something?   I suppose I could be an idiot, but don't I need to install the driver on my PC?   I realize I don't need to update the firmware.   I downloaded the FaderPort.dll file and put it in the appropriate folder for Sonar, but I can't register it or load it, I assume, because I can't install it because I don't have the installation file.   Windows 10 has been around for awhile now so surely there's a driver for it?    Any help would be appreciated.    First experience with PreSonus is kinda choppy here.    Thanks

Oh, and I apologize if this is a duplicate question - I did not get a confirmation response saying my question was even received.   That goes for opening a ticket with support as well.   Yep - I'm registered.   Thanks

4 Answers

0 votes
answered Apr 19, 2017 by AlexTinsley (924,900 points)
Best answer

The FaderPort is a class compliant USB MIDI Interface. It already has the most up to date firmware on it version 1.3.8. 

There is NO device driver for the the FaderPort, so there is no PC installer because it is working as a class MIDI device. 

There are DAW profiles available that folks mis-interperet as a PC or Mac Installer. 

The DLL files used for supporting the different DAWs are available in this knowledge base area

Note, some DAWs have custom DLL support, while others are only supported through HUI or Mackie modes. 

0 votes
answered May 25, 2017 by andrefernandes1 (380 points)

I am super disappointed with PreSonus. They market it as compatible with Win 10 but I have tried everything to get it to work with Sonar and nothing, they don't even care to reply to my support ticket. Horrible experience, so far.

Windows 10 Pro | 64 bits | intel core i7-7700 CPU @ 3.60GHz | 16GB

1) I connected it my PC (regular USB with a MIDI keyboard also plugged) and it ran an automatic "install" so I was hoping it'd be plug and play. When I tried to connect it to Sonar, FADERPORT didn't appear in the Control Surfaces;

2) I read the manual but there was no CD so I created an account on your website and download the firmware update. When I ran it I got an error message: "Error: Could not find FaderPort control surface. Check the cables to ensure it is properly connected and press Next to try again";

3) I tried again, this time I disconnected all other MIDI devices and tried it on USB 2.0 and regular. Same error.

4) After this, I tried an older installer I found here:
It would run an installer (but not inserting the dll files) and then open again the recent firmware update that gives the error message.

5) As I couldn't get the installation done directly through plug or using your firmware and installer, I tried your manuall .dll install:

I copied the file to the right directory [C:\Program Files\Cakewalk\Shared Surfaces] but when I run the regsvr32 or C:\windows\SysWow64\regsvr32 register for FaderPort.dll I get the following error: "The Module FaderPort.dll failed to load. ...."

So, I don't know what else to try and I feel deceived.

0 votes
answered May 28, 2017 by andrefernandes1 (380 points)

I was able to install it in WIN 10/ Sonar Platinum, after a lot of struggle.

1) If you get an error when trying to manually register the DLL, just download this microsoft MS Runtime:

2) After registering it, check if your device name (in your DAW) is "FaderPort Update Mode". If so, it happens that when the firmware update results in the error, that turns the device into that Null entity, that doesn't work. You just have to uninstall FaderPort and remove all entities from the Device Manager ( in "Audio,Video,Game controllers"). Them restart Windows and it will re-install it "virgin", to work.

0 votes
answered Feb 10, 2020 by ajcannon (140 points)
Upon having similar issues, this was the only article/forum I could find of anyone having a similar problem.

I just got a Faderport 8 second hand to run with Studio One 3 on a Windows laptop  At first it wasn’t communicating properly with the software. A little research and I realized I needed to update S1. I updated S1, downloaded firmware for the controller and tried again. Still not working. Then it came to my attention that Universal Control was not up to date. I updated UC which also allowed me to now have access to even newer firmware for the Faderport which I quickly downloaded and installed. Now that everything was up to date I figured it would work great. Wrong. Still not working but now S1 wasn’t even recognizing it as being plugged in. Then I opened my device manager to find that Windows wasn’t recognizing it either. The only thing recognizing it was Universal Control. Being at the end of my rope and going into about the fourth hour of turmoil, I factory reset the device and suddenly it was connected. So I opened UC back up and updated the firmware once again. NOPE. Now the Faderport was once again not connected. Not a trace of it. I factory reset it once again and this time did not update the firmware. Voila. Worked perfectly with S1. My best guess is the newest firmware has a bug that never got patched. Running the older firmware and making sure S1 is up to date.

Hope someone stumbles across this like I did.