Questions & Answers

Can't update firmware FADERPORT 8

0 votes
783 views
asked May 25, 2017 in FaderPort 8 by wildergervasio (250 points)
Hi,help me, when I try update firmware from 1.01 to 1.10 (Universal Control) it show a error.

Multiple devices of same type connected. Please disconnect all but one to update the firmware.

But I have just 1 faderport 8.

Thanks

9 Answers

0 votes
answered May 26, 2017 by AlexTinsley (696,590 points)
 
Best answer
The problem is that you must also own a FaderPort original, and Audio MIDI Setup has some duplicate information that needs to be cleared out so the Mac see's the FaderPort 8 correctly.

Below are the instructions on how to properly set up the Faderport 8 on your Mac:
------------------------------------------------------------------------------------------------------------------------

1) First, please turn off the FaderPort 8 and quit Universal Control.
2) Next, open Application folder, then Utilities Folder. then open the Audio/MIDI Setup application on your Mac.
3) Then, in the menu bar go to Window > MIDI Studio
4) Once you are in the Midi Studio, remove the FaderPort 8 from the device list.
5) Upon removing the FP8 from the device list; go ahead and  Power Up your FaderPort 8 while also holding down the first two select buttons ( located at the top left of the FP8; above Faders 1 and 2) at the same time. [ Putting you in the FP8's Operational Configuration Mode ]
6) Verify that your FaderPort 8 is setup in the proper Operational Mode for your DAW.
   - Native Mode for Studio One , HUI Mode for Pro Tools, and MCU (Mackie Control) for other DAWs.
7) Once you have properly selected the operational mode for your DAW; open Universal Control and go ahead and check for firmware updates by selecting " Check Firmware " in the drop down menu.
8) If Universal Control alerts you that there is a firmware update available, go ahead and proceed with the firmware update process at this time.
**please note: do not power down your computer or Faderport 8 during this update process.
9) Once you have checked for updates and or updated your FP8's firmware, proceed by opening up your DAW of choice, configure the FP8 and testing the FP8 in a new session.
+1 vote
answered May 28, 2017 by henninghenning (430 points)
I have the same problem. But i use a pc and no mac. Anybody have some tips.
+1 vote
answered May 29, 2017 by wildergervasio (250 points)
My OS is Windows (Windows 10) too. How can I do that please?
0 votes
answered May 29, 2017 by michaelkrusche (230 points)
WTF! I have the same problem and I'm working with Win 10 too!
0 votes
answered May 30, 2017 by timofinkbeiner (2,430 points)
Hi,
I have also the same Problem on PC (Windows 10). Hope for a solution from Presonus soon.

Timo
0 votes
answered May 31, 2017 by wildergervasio (250 points)
Good news Presonus?
0 votes
answered Jun 6, 2017 by yvesgalliot (210 points)
Hello Presonus...

Can you help the windows's user now, please ?

Tks

Yves
0 votes
answered Jun 7, 2017 by timofinkbeiner (2,430 points)
Hi,

I have the same problem and I tried it several times with a desktop-pc with Windows 10, a Windows 10-tablet and a older laptop with Windows 10 and also Windows 7. Every time I had the same problem and messages.

I opened also a support-tickert and wrote this to Presonus and they worked to find a solution. Their first answer with deleting hided devices of faderports in the device-manager didn't work. So I hope they find another way.

It Looks like there must be a general Problem with the UC 2.1 - software with Windows. The older version of Universal Control with firmware 1.01 worked under the same windows-versions on the same pc's.
+1 vote
answered Jun 14, 2017 by timofinkbeiner (2,430 points)
Hi,

there is another workaround to make the upgrade to 1.10, posted by thorstenmustermann in the old forum. Here is the link and the original text. Hope it is ok to post it here.

Link to the old forum:
https://forums.presonus.com/viewtopic.php?f=337&t=25681&p=143667#p143667

I found another (easy) solution:
Windows users: Please download the legacy UC version 2.0.2 from the PreSonus download page again - uninstall the current UC version 2.1 from your computer - install again the legacy UC version 2.0.2 and copy the UC file "windowsmidi.dll" from C:\Program Files\PreSonus\Universal Control\Plugins to a place your choice on your computer (probably on desktop) - uninstall the legacy UC version 2.0.2 again and install the current UC version 2.1 on your computer (probably you have to restart your computer) - override then the original "windowsmidi.dll" file in C:\Program Files\PreSonus\Universal Control\Plugins with the older "windowsmidi.dll" file from UC version 2.0.2 saved before on desktop - connect your Faderport 8 with your computer - start UC version 2.1 and start the firmware update to version 1.10 - DONE!

So in this case I'm thinking the "windowsmidi.dll" file from UC version 2.1 is still corrupt. Please dear PreSonus team correct this immediately. Thank you very much.
...