Questions & Answers

Audio not working. Sierra Mac to 16.4.2 PreSonus.

0 votes
asked Jul 20, 2017 in FireStudio Series by aokikamawara (150 points)
I am currently running MacOS Sierra. I downloaded the 1.74 driver. The Universal Control identifies and responds to changes on the 16.4.2 mixer. My output is set for PreSonus Firestudio.

Yet, no audio seems to be coming through the board.

Any suggestions?

4 Answers

0 votes
answered Jul 27, 2017 by butchrichard (131,360 points)
Best answer

Check the Firewire Returns.  Section 2.5 of the software reference manual will illustrate.

0 votes
answered Jul 28, 2017 by mike.lyons (140 points)
In Logic Pro X (v 10.3.2) try using System Setting (in lieu of Presonus) in Audio Preferences INPUT DEVICE and OUTPUT DEVICE. Making that change enabled me to Record audio tracks in OSX10.12.6 (latest Sierra update to date) on FireStudio Mobile (16.4.2 UC Firmware v1.7.4)
+1 vote
answered Dec 12, 2017 by Jeff Martindale (900 points)

Jeff MartindaleToday at 22:24

This is the fix: 
first: Unplug your Presonus from the Mac Computer firewire port:

Check your mixer in "System" to make sure it is on Device I.D. #0 !!!

Follow Procedures to" UNINSTALL universal control" 
Remove files as explained,( I followed all procedures) 
SHUT down, (Not Restart).

Start Up MAC, 
goto : Applications / UTILITIES 
Open "Disk Utility" 
run "First Aid" or click on "Repair Permissions".


Restart Mac, 
while holding these keys down on the keyboard: 
"Command + Option + R + P" 
wait until you hear the 2nd Start Chime from your Mac, 
then release the keys. 
This "Resets"/ Zaps Your PRAM.


Restart Mac, 
Open latest dmg package of Universal Control from Presonus (( 
INSTALL the package to your Computer. 
do NOT shut down at this point:

This is the part that is NOT in some instructions: 
GOTO : System Prefs/ Security+Privacy,/ General, 
There will be a note that says something like 
"T.C. Electronics was blocked while install......" with a button.: "ALLOW" ?

Yes ALLOW this !!! 
That completes the install !!!!

RE plug your Firewire into the Mac computer, and wait a minute.

Check your System Prefs / SOUND, 
You should see the Presonus as a choice again.

Upon restart or Shut down and starting up again you run into the same problem: 
(not seeing the mixer on the Mac) 
go through the procedure AGAIN meticulously.

It worked for me after many restarts/shut downs/ and fuse box switched off, then on before start up.

Presonus Studio Live 16.4.2 (Classic) firmware 1.50a build 190 
Universal Control 
Mac mini OSX 10.13 High Sierra 
Studio ONE

0 votes
answered Jul 16, 2019 by ill studio (150 points)
Thank you Jeff for given solution. I notice that Universal control stopped working and my Midi also stopped working. After fresh OS MAC Mojave I notice that my driver were unrecognised. I tried my level best but could not be anything. Then I saw your suggestion and followed step by step. Although now PreSonus has latest Universal control 5875. But this won't work until below instruction been followed. Now my Persons Studio Live 14.6.2 working and MIDI as well perfectly.  Everything working in order now.Thank you.