Questions & Answers

Make 16.4.2 (Non AI) show up on High Sierra with Firewire to thunderbolt Adapter.

+2 votes
788 views
asked Oct 7, 2017 in Classic Mixers by stephennichols1 (220 points)
I made the mistake of updating to High Sierra without first checking compatibility. I have uninstalled and then reinstalled 1.7.4.5 multiple times but my mixer interface still is not recognized. I have the old 16.4.2 pre AI. Am I doing something wrong or do I just need to wait for another dirver update? I am running a firewire to thunderbolt adapter and everything was working perfectly pre update. Also I use logic but also have studio one. Either way nothing is working. Yes I have restarted probably 100 times and reset PRAM. I am on a late 2013 i7 imac and recently reformatted everything because I needed a refresh.

6 Answers

+1 vote
answered Oct 10, 2017 by michaeldach (160 points)
It's the same here with my 24.4.2...
0 votes
answered Oct 11, 2017 by stephennichols1 (220 points)
 
Best answer
I was able to fix my issue so I figure I would update anyone with the same issue. First I manually deleted all of the files associated with presonus. Google search manually delete presonus studio live drivers Mac then follow those instructions to the letter including deleting the hidden files. Then shutdown and start back up while resetting pram (in same instructions). Then install the correct driver again from a fresh download. Restart immediately and this all worked perfect for me. Hope this helps!!!
0 votes
answered Nov 4, 2017 by daviderossi (150 points)
I have the same problem after a high Sierra clean install
0 votes
answered Nov 17, 2017 by Deech (720 points)
Same issue with my RM16. S1 and Capture wont' read it. And put in a ticket to Presonus days ago and haven't heard anything.
0 votes
answered Nov 30, 2017 by MikeN47 (270 points)
I am having the same issue, except my FireStudio Project is recognized (and not my StudioLive 16.4.2). The iMac does recognize them both as hardware devices, but only the FireStudio Project is being recognized as an audio device.
+3 votes
answered Dec 12, 2017 by Jeff Martindale (540 points)

Jeff MartindaleToday at 22:24

This is the fix: 
first: Unplug your Presonus from the Mac Computer firewire port:

Check your mixer in "System" to make sure it is on Device I.D. #0 !!!

Follow Procedures to" UNINSTALL universal control" 
Remove files as explained,( I followed all procedures) 
SHUT down, (Not Restart).

Start Up MAC, 
goto : Applications / UTILITIES 
Open "Disk Utility" 
run "First Aid" or click on "Repair Permissions".

SHUT DOWN.

Restart Mac, 
while holding these keys down on the keyboard: 
"Command + Option + R + P" 
wait until you hear the 2nd Start Chime from your Mac, 
then release the keys. 
This "Resets"/ Zaps Your PRAM.

SHUT DOWN.

Restart Mac, 
Open latest dmg package of Universal Control from Presonus ((1.7.4.2)) 
INSTALL the package to your Computer. 
do NOT shut down at this point:

This is the part that is NOT in some instructions: 
GOTO : System Prefs/ Security+Privacy,/ General, 
There will be a note that says something like 
"T.C. Electronics was blocked while install......" with a button.: "ALLOW" ?

Yes ALLOW this !!! 
That completes the install !!!!

RE plug your Firewire into the Mac computer, and wait a minute.

Check your System Prefs / SOUND, 
You should see the Presonus as a choice again.

Upon restart or Shut down and starting up again you run into the same problem: 
(not seeing the mixer on the Mac) 
go through the procedure AGAIN meticulously.

It worked for me after many restarts/shut downs/ and fuse box switched off, then on before start up.

Presonus Studio Live 16.4.2 (Classic) firmware 1.50a build 190 
Universal Control 1.7.4.2 
Mac mini OSX 10.13 High Sierra 
Studio ONE 3.5.4.45392

...