Questions & Answers

CPU refuses to clock up--poor single-thread performance

+3 votes
213 views
asked Aug 17, 2017 in Studio One 3 by keysmcgee (230 points)

Before I dive in, here are my system specs
Intel Core i7 7800x (6c12t @3.5/4.0 GHz boost)

16GB Ram (2x8 GB) in dual channel (DDR4-3200)

Samsung 960 evo SSD

GTX 750Ti

VANTEC UGT-FW200 (3-port FireWire 400 card)

Presonus Firestudio Project

Studio one 3.5.1.43560 (fresh install as of last night)

Previously, I have used Studio One 3 Professional on a PC with an Intel i7-6700k, overclocked, with XMP enabled on memory, and never ran into any sorts of issues with CPU usage, even on large projects with lots of audio processing or many VSTI's. Studio one was remarkably stable, and nothing I was able to do would break it or crash it. Now that I have this PC, I am running into nonstop CPU usage issues. 

http://imgur.com/a/L25aj    Here is an imgur link to 3 screenshots.

The first screenshot is after I opened a relatively small project just after rebooting, and clearing my CMOS. All BIOS settings are at default, no overclocking on the CPU, no XMP or manual overclocking on the RAM, and the windows power profile is set to balanced. In addition to these settings, I uninstalled, manually deleted all system files related to Studio One (progamdata/appdata folders, etc...) and installed fresh.

The second screenshot is what CPU usage shows as when I hit play. It hits one core hard, and as expected, the clockspeed on that single core goes up to its max boost of 4GHz, as indicated by HWMONITOR (Clocks: Core#1). Usage on the single-core performance side is very high, consistently in the 80% range, which isn't unheard of when using NI Razor (I am) and other VSTI's. That being said, the graph always registers somewhere between 70 and 90% usage, but playback is frequently interrupted by clicks and pops, indicating that the core is being maxed out! To summarize: One core of the CPU boosts up in speed, but appears to be maxed, despite reading around 80% average usage (meter bobs between 70-90%)

The third screenshot is the results after switching my power profile to high performance, which forces all cores on the CPU up to their full speed. Now, all cores are at 4GHz, and still, only one core is being used heavily, but that core's usage is half of what it used to be! What's up with this? 

CRITICAL DETAILS BEFORE EVERYONE JUMPS ALL OVER ME FOR THIS ONE:

Yes, I did see the forum post with the person with the i7-6800k (or something similar, a roughly equivalent chip to mine), and yes, I have tried disabling Intel Speedstep/Enhanced Turbo in the BIOS. This has the same effect as switching power profiles in windows, preventing the CPU from ever clocking down, but I can't disable/reenable it (relatively) easily from the OS. In addition, when I run my CPU overclocked (or even when I don't) I would prefer to have the CPU using as little power as it needs to, as running it at a higher speed and power consumption when it doesn't need to be contributes to shortening its life.

Yes, I understand that currently multicore support for virtual instruments is all but nonexistent. That still doesn't explain the 2x performance difference of forcing all cores' clockspeeds up vs just the one core that clocks up automatically during playback. 

Any insights on possible fixes on my end or upcoming updates/patches with improvements are much appreciated. Thanks for your time.

1 Answer

0 votes
answered Aug 17, 2017 by brianmeisner1 (183,260 points)
 
Best answer
In looking at your screenshots, it appears that you have the Dropout Protection set to "Minimum."  The first thing that I would recommend that you try is to go into Studio One>Options>Audio Setup>Processing and set your Dropout Protection to "Maximum."  This will allow you to run with a lower latency when recording and give you the needed processing power for playback.  Here is a link to a knowledge base article that explains the new Low-latency monitoring and Dropout Protection that was introduced in version 3.5.  

http://support.presonus.com/hc/en-us/articles/115002611926-Studio-One-3-5-Audio-Dropout-Protection-and-Low-Latency-Monitoring-FAQ
...