Questions & Answers

Anyone tried PreSonus FireStudio Project with MacOS High Sierra 10.13?

+1 vote
1,751 views
asked Sep 25, 2017 in FireStudio Series by eriknordlund (250 points)
MacOS High Sierra (10.13) was publicly released by Apple today, and the current release notes for Universal Control don't mention support for High Sierra yet. Has anyone taken the plunge, and if so is it working well? I'm using three FireStudio Projects, and I plan to test them out on another partition to see if it works, but that will take some time. I'll be sure to update this post with results when I have them. Thanks!

9 Answers

0 votes
answered Sep 25, 2017 by eriknordlund (250 points)
So far so good... Universal Control installation went as expected, and all three of my FireStudio Projects are syncing with solid blue lights.

In Logic Pro X, everything’s working for me just as well as in Sierra 10.12. Personally, I’m going to go through with the update. I wouldn’t recommend it to others until PreSonus officially supports High Sierra 10.13, but I’m experiencing zero problems and I’m a bit of a geek so wish me luck! Hopefully my experience helps someone. If anything changes, I’ll update this again.
0 votes
answered Oct 4, 2017 by bricechevallier (140 points)
Hey there ! I did the High sierra update and I can't find my fire studio project anymore with the latest drivers.

Could u help me ? How did you fixed it ?

Brice.
0 votes
answered Oct 5, 2017 by eriknordlund (250 points)
Hey Brice,

I didn’t run into that problem, but have you tried uninstalling and reinstalling the drivers?
0 votes
answered Oct 24, 2017 by ncmatt (140 points)
Hi Erik,

Did you ever have any compatibility issues with the current driver on High Sierra?  I need to do a clean MacOS install but I’m concerned that there hasn’t been an updated version of Universal Control for the new OS, since I had connectivity issues once in the past after updating.

Any insight is appreciated!
0 votes
answered Oct 25, 2017 by eriknordlund (250 points)

I did test the driver on a clean install of High Sierra before updating my main install of Sierra, and it seemed to work just as well as on Sierra (I didn’t experience any issues personally, but different hardware configurations could vary).

I think I remember experiencing an issue a year or two back where the interface wouldn’t sync with the computer, and that definitely isn’t happening to me this time around.

If you have an external drive that you could run a test install on, I would recommend trying that to see if you feel confident with your hardware before committing to the change. You can follow this tutorial to try it out: https://www.macworld.com/article/3204672/macs/how-to-create-a-bootable-macos-high-sierra-installer-drive.html

Good luck!

0 votes
answered Nov 17, 2017 by Deech (720 points)
Since updating, my Mabook Pro won't read my RM16 that's connected via firewire. Was working fine till I updated! Not sure what to do now.
0 votes
answered Dec 1, 2017 by fernandojimenez3 (140 points)
I'm also having issues, it was working perfectly until I updated to High Sierra. I tried the lengthy manual uninstall procedures twice now and still nothing. Apple won't even give me the option to go back to the previous OS version I had. What did you guys do to get it to work?
0 votes
answered Dec 12, 2017 by Jeff Martindale (500 points)

Jeff MartindaleToday at 22:24

This is the fix: 
first: Unplug your Presonus from the Mac Computer firewire port:

Check your mixer in "System" to make sure it is on Device I.D. #0 !!!

Follow Procedures to" UNINSTALL universal control" 
Remove files as explained,( I followed all procedures) 
SHUT down, (Not Restart).

Start Up MAC, 
goto : Applications / UTILITIES 
Open "Disk Utility" 
run "First Aid" or click on "Repair Permissions".

SHUT DOWN.

Restart Mac, 
while holding these keys down on the keyboard: 
"Command + Option + R + P" 
wait until you hear the 2nd Start Chime from your Mac, 
then release the keys. 
This "Resets"/ Zaps Your PRAM.

SHUT DOWN.

Restart Mac, 
Open latest dmg package of Universal Control from Presonus ((1.7.4.2)) 
INSTALL the package to your Computer. 
do NOT shut down at this point:

This is the part that is NOT in some instructions: 
GOTO : System Prefs/ Security+Privacy,/ General, 
There will be a note that says something like 
"T.C. Electronics was blocked while install......" with a button.: "ALLOW" ?

Yes ALLOW this !!! 
That completes the install !!!!

RE plug your Firewire into the Mac computer, and wait a minute.

Check your System Prefs / SOUND, 
You should see the Presonus as a choice again.

Upon restart or Shut down and starting up again you run into the same problem: 
(not seeing the mixer on the Mac) 
go through the procedure AGAIN meticulously.

It worked for me after many restarts/shut downs/ and fuse box switched off, then on before start up.

Presonus Studio Live 16.4.2 (Classic) firmware 1.50a build 190 
Universal Control 1.7.4.2 
Mac mini OSX 10.13 High Sierra 
Studio ONE 3.5.4.45392

0 votes
answered Mar 13 by anthonyireland (140 points)
I'm still struggling with this.

After countless uninstall and reinstalls my RM16ai fails to be seen.

I do an uninstall. Restart

Then reinstall. Restart

Then RM16ai shows up.

After a shutdown and start up again back to not showing up

I'm on high Sierra 10.13. Seems to be worse since that upgrade. Was infrequent before that but happens every time now!!
...