Questions & Answers

My Quantum 2 won't connect to my Mac (OS: High Sierra 10.13.5).

+2 votes
asked Jul 19, 2018 in Thunderbolt - Quantum by seedyofficial (550 points)
I have been trying for a couple of days to connect my brand new Quantum 2 to my Mac. I have made sure that my Thunderbolt cable is not a display cable. I have installed and re-installed Universal Control. When installing, I went to Security & Privacy settings and allowed the exception (mentioned in other solutions). I have restarted my Mac several times throughout this process. I have unplugged the Quantum 2 and Thunderbolt cables in what seems like every possible order. Important note: when I first plugin the Thunderbolt cable, the power button light will flash blue 3 times but then stay red indefinitely. Please help.

5 Answers

+1 vote
answered Aug 4, 2018 by seedyofficial (550 points)
selected Aug 28, 2018 by connorguiberteau
Best answer
They actually were able to resolve this for me when I opened an official support ticket with them. I had to use the uninstaller that comes with the universal control .dmg file. Then restart. Then reinstall and allow the exception again in Security & Preferences.

See this article for more information:

Hope that helps.
+1 vote
answered Jul 22, 2018 by lukehatton (160 points)
I'm in a similar situation with my Quantum 1; just so you know you're not on your own! I have raised a ticket with Presonus so I'll let you know if i get any useful feedback.
+1 vote
answered Aug 3, 2018 by joshhall8 (170 points)
I have the exact same problem.  My Mac Pro will not recognize my Quantum 2 at all even though I've used different cables and un-installed and re-installed the UC 2.8 driver.  I spoke directly to Apple Care and it is not a computer/OS issue.  I asked presonus support and they recommended all the cable swaps and driver changes....I am beginning to think this is Studio One not keeping up with the MacOS high sierra updates....?  Has anyone gone back to a previous OS?  I can't get any of the presonus support recommendations to work....$7k worth of brand new Presonus gear and can't get a bit of it to work because the Quantum 2 won't work with a brand new Mac....
0 votes
answered Oct 11, 2018 by michaelkuplic (140 points)

I had the same problem with my Quantum Quad 2 with my 2012 Macbook pro. I switched out the cables to an Apple one... it didn't work. I did the uninstall. and Reinstall multiple times.

This is what did work.

1. Did the uninstall. Restart. Unplugged the thunderbolt 2 cable.

2.  Then I upgraded my OS to Mojave. I then looked to download Mojave but they only have High Seirra, 

3. Did the uninstall again. Clicked the Allow in the Security section.  (No restart)

4. Then I installed the High Sierra version opened UniversalControl, and boom blue light!  It all works now. Both the Mac thunderbolt cable and the Cable Matters [Certified] Thunderbolt Cable/Thunderbolt 2 Cable Black 6.6 Feet.  Both work for me.

0 votes
answered Dec 20, 2018 by martinpettersson2 (140 points)
I had the same problem (seems like it anyway) and I solved it by connecting my new Quantum 2 to a different machine (in my case an old iMac ~2009, same cable). I was then able to establish connection and was also prompted by UniversalControl to upgrade firmware. After doing that according to instructions I could reconnect it with my current machine (Mac Pro Trashcan). After this all works fine.

As a side note, I turned the cable around (switching the ends of the cable), but I really don't think that's the solution, but hey, I don't know the TB specs.