Questions & Answers

Firestudio stopped working - flashing red/blue - on High Sierra update. Uninstall & reinstall fails.

0 votes
247 views
asked May 16 in FireStudio Series by stevemcallister1 (150 points)
Foolish of me to update without verifying compatibility. Until now Mac OS and Firestudio have been rock solid.

Upon upgrading, I now get flashing red/blue. I've walked through manually uninstalling & reinstalling multiple times - same result.

Late 2013 iMac, running 10.13.4

Any help would be greatly appreciated.

Thank you

2 Answers

0 votes
answered May 18 by AlexTinsley (733,660 points)
 
Best answer
Apple introduced a new feature in High Sierra that if goes unchecked will not allow installation of driver kext files into your system.

Please read this article which may resolve your issue: https://support.presonus.com/hc/en-us/articles/115005456483-Installation-Issues-with-Universal-Control-on-High-Sierra-Mac-OSX-10-13

Also depends on which FireStudio you have. Looking at your account you have no products registered. Please take a moment to do that.

This only applies to FireStudio Project, Mobile, Tube, Lightpipe, SL1602, SL2442 and SL1642.
0 votes
answered Nov 16 by techsinthecity (170 points)

Hey. OK you need to configure System Integrity Protection using the csrutil terminal command .... unknown why I stumbled over this fix for another audio interface tried it and was all good for me. 

Reboot holding Command & R

Run Terminal, type:

csrutil disable

Reboot.... should be sweet... assuming you have Universal Control correctly installed, patched unit in etc etc

Hope Ive added some value, laters 

PS rerun if it stops working after updates

...