Questions & Answers

Eris E8 emitting a burnt ozone smell?

0 votes
351 views
asked Oct 9, 2017 in Sceptre, Eris, R-Series by arlowest (200 points)
I recently bought a pair of the Eris E8's from Sweetwater. Powered them up yesterday and they do sound really good. Both lights work and everything appeared normal and fine.

Let them run for about an hour and then started smelling a terrible burning smell like ozone or electrical component. Both speakers were still working fine but the smell was really unusually strong from one. Kinda worried me so I called Sweetwater and they are sending me a new speaker thinking I had narrowed the problem down to one speaker.

Well, packed it up and got it ready for the replacement and let the room air out a bit. Turned on the second one and let it run for a bit. The second speaker seems to be emitting the same smell. Burnt electronic is all I can compare it to. Something hot and emitting an ozone like smell. Like a blown coil smell.

Is this smell a common issue with these speakers or has anyone else had this happen?

Now I am thinking about returning them both. Its a shame I really like the way they sound but this smell is overwhelming in the studio.

I wondered if they needed to just break in? Don't want them to burn up the studio either.....

3 Answers

0 votes
answered Oct 10, 2017 by arlowest (200 points)
Ok, so let the second one stay on all day and no smell at all. I think it was just one bad speaker at this point. Sending that one back and getting a replacement. Glad I got it at Sweetwater they rule and always back up everything they sell.

Let you know what the replacement does when I get it.
0 votes
answered Oct 11, 2017 by arlowest (200 points)
Ok, replacement came today. Plugged it in and no problems at all. Seems as though I just had the one bad one. The burning smell was so bad it took a couple days to get it out of the studio. All is well and the speakers sound fantastic.

Will be sending back the bad one.
0 votes
answered Feb 24, 2018 by shawnmurray1 (140 points)
I have the presonus eris e8 and the power don't come on and I don't know what happen to the speaker but the blue light don't come on could this be a fuse
...