Questions & Answers

iPads will no longer connect to studio computer via UC Surface

+10 votes
asked Dec 20, 2017 in Studio 192 USB 3.0 Interfaces by marcmiller (530 points)
I have a single studio computer that is connected to a Studio 192 on it.  I have an iPad (OSX version 9.3.5) that is running the latest version of UC Surface ( that used to connect just fine to the studio computer, but has recently stopped connecting.  When I start the app on the iPad, it shows the studio computer (and the correct IP address) as a possible connection, but when I tap it, nothing happens.  I tried installing UC Surface same version to a new iPad (running OSX 11.2.1) and the exact same thing happens.

I have verified that Universal Control is allowed thru my firewall, as well as verifid that the PresonuseHardwareAccessService.exe is also allowed thru the firewall, and I have also verified that UDP port 47809 is allowed thru the firewall.  The studio computer's UC Surface software connects fine and I can control the mixer and all functions from the local computer, but not from remotes and this used to work.  I have followed what (very) scant troubleshooting information is available on this and a few other boards, but nothing works.  It's not a deal-breaker, but I really do like have the UC Surface running on the iPad for quick changes to settings as well as being able to control the talkback mike.

There have been no updates to software here, either the OS or anything else.  I can verify that.

Anyone got any ideas here?  I'm truly stumped- I'm very well versed in networking, and really don't want to go thru a "please dump your settings/reboot your computer" kind of troubleshooting, because I've already done all of that about 35,312 times already.  HELP!!!

11 Answers

+3 votes
answered Dec 21, 2017 by saracarter1 (390 points)

I'm having exactly the same problem with that version of UC Surface on my iPad when it all used to work fine. I've just updated to the latest firmware on the Studio 192 which hasn't helped. I'm on a mac pro running Sierra and my firewall is off. I've deleted and reinstalled UC Surface on the iPad and got the latest iOS.

+4 votes
answered Dec 21, 2017 by albertoleal (570 points)
I´m having the same problem. It is really disappointing - I had a really big session this week and it didnt work at all. The iPad display the my Studio 192 but I tap on it and nothing happens. - Honestly, the connection between UC surface on iPad and my computer was never stable or reliable, but now it doesnt connect at all.

Running UC Surface on iPAd with iOS11 and UC on W10
+3 votes
answered Dec 22, 2017 by davidsimms2 (260 points)
Yep, the latest update to the UC Surface on my computer killed my iPad and Android controls. It's not an option. You should be able to click the settings wheel on your computer to config the iPad or Android device, but that's no longer an option for the 192. Kind really irks me that the main reason I bought the 192 is for this feature. Presonus devs need to just add this few lines of code back into the software.
+2 votes
answered Dec 24, 2017 by jasonringer (220 points)
Same here.

Come on Presonus, this is getting ridiculous.

3 of the last 6 updates have caused me to have to jump through hoops to get UC surface working. And this time, those hoops don't work. I think your app is broken.
+3 votes
answered Dec 30, 2017 by pbaudinat (300 points)
Any idea of the way to install an older (and working)  version of UC SURFACE on an ipad 2 ?
0 votes
answered Jan 5, 2018 by mksyzhap (250 points)

me too!!!

I'm android 

When I click on it, nothing happens

+1 vote
answered Jan 12, 2018 by davidsimms2 (260 points)
Same issue here. I tried rolling back the software, but you need to roll back the firmware on your device (Studio 192 for me) and remove all traces of the driver and UC from your computer's registry. It's a huge pain and not worth the trouble. The easy fix is just adding the code back into the next update to UC.
+2 votes
answered Jan 14, 2018 by jjguitarist (230 points)
I am having the same exact issue! I made sure that everything is up to date, re installed uc surface, and rebooted ipad. Still nothing. My 192 shows up but when clicked it does nothing. To rule out any problems with pc settings or home network settings I tried the Studio One RC and it works flawlessly. I also downloaded the Qmix-UC and it controls my 192 fine. So the problem must be with the Ipad uc surface ap or UC software on the pc. Hope they remedy this soon!!
+1 vote
answered Jan 15, 2018 by kevincollins1 (920 points)
I had to downgrade UC. I opened a ticket and that was the advice. Said should be fixed ni next update.
+6 votes
answered Jan 31, 2018 by marcmiller (530 points)

Since Presonus Support is of absolutely no help whatsoever (for darned near everything on this forum- AHEM) I thought I'd let folks know that updating to the Jan. 30 2018 Universal Control 2.5.2 fixed the problems I was having.  I can now connect my iPad as well as my phone (Google Pixel XL) to the Studio 192 and everything works as expected.  HOWEVER- my Surface Pro 4 will still not connect via wi-fi to my studio computer- but I'm good for now.

As long as I'm here, I have to give a GIGANTIC thumbs way down to Presonus Support.  They are completely MIA, and when they do respond it's only to say "Please open a ticket" with a poll attached to it, and then that gets ignored.  Like everyone on this board, the money I've invested in your products is not insignificant, and I expect to get at least some kind of interaction, and yet none is had.  I love my Studio 192 as well as my DP88's and my Faderport, but when something goes wrong with them my blood runs a little cold because I know full well that I'm on my own in trying to fix it.  Luckily, I'm pretty tech-savvy, but not everyone is and I'm very sure that others are having the same issues I've had with far less luck.  I also realize that since Presonus support is completely MIA, they most likely will not see this post, but I had to get it off my chest.  PLEASE, support dudes and dudettes- your customers are your life's blood and they need your help.  Do your jobs and give us the support we need since we are doing our jobs out here supporting you by purchasing, using and evangelizing others to your products.

0 votes
answered May 23, 2019 by Curly2 (140 points)
I bought a brand new Presonus Stusio 192 a few days ago and I have the same problem as you. UC Srface on my iPad cannot connect to my PC desktop. It can see the device, but won't connect. Can anybody at Presonus have any suggestion how to fix this? I had done a lot things for a few days (firewall, tried on another PC etc etc, but still failed to connect. PLEASE HELP!!!!!!!