Questions & Answers

Connection loss to RM32ai wireless and firewire

+7 votes
asked Jun 4, 2018 in Ai Mixers by stuarttrotman (300 points)
Hi There

I am having connection issues between my RM32ai and all wireless and firewire connections. My setup has been consistent for the last year and everything has worked well but the other day I lost connection twice in one show. My iPad went blank on UC Surface 2 and I could not connect to my Mac over the firewire connection either.

Only a reboot would resolve the issue which is highly embarrassing to explain to an audience twice in one show!!!! The unit would still run live even though there was a connection issue which was good but still no way to change any levels or aux mixes.

This is a very serious issue as it makes me very nervous about it happening again. I have looked for this issue on the forum and have found a few instances of this situation but with no real definitive answers. I have never had this problem before now and the only change that has been made is updating the UC surface software.

Has anyone else had this experience and found a solution?

11 Answers

+5 votes
answered Oct 24, 2018 by betogrimaldo (730 points)
selected Oct 24, 2018 by stuarttrotman
Best answer
Im having the same exact issue i have a rm32 ai and a cs 18ai i too had too shut down and reboot twice . It is a very embarrassing to deal with twice during a live performance while streaming. Presonus has not provided a solution is it because they have a new board. It all started when i uploaded there new update.  I had the board a lil over a year. Please provide help.
–6 votes
answered Jun 22, 2018 by Michael Martin (89,010 points)

We have a Beta Firmware release for AI Mixer users. One of the issues addressed in this Beta is potential crashes, lock ups, or loss of control.

I suggest following the link below and installing the Beta Firmware. This should provide a stable solution. Please report any feedback in this forum area as well. We want to hear about your experience with the Beta Firmware.

+1 vote
answered Oct 30, 2018 by attilagaal (180 points)
The same thing happening with my mixer as well, altough it is a RM16ai. I allways lost the firewire connection between my Mac and my mixer. Sometimes I'm unable to reconnect in any other way than restart the whole system. It's frustating.

I could do the whole control thing from wireless network, but I need the firewire connection for measuring the room before the performance and get the music input from my music library.
+1 vote
answered Nov 5, 2018 by renekrol (260 points)
I'm having the same problems too. Setup with RM32AI, CS18AI and Capture 2 on a Apple MacBook (for recording purposes). Yesterday during a show all connections we're lost 2 times. First CS18AI lost his wired connection to the RM32AI and everything went out no sound left in the house. The only thing to do was to reboot the RM and CS. I disconnected the Macbook connected via firewire to the RM32AI and the complete freeze of the complete system didm't occur again. Last week i updated the RM32AI and the CS18AI to the latest firmware and i installed also the latest version of Capture 2 on my MacBook (with Mojave version 10.14.1). It is very embarrassing to restart the complete system twice ;-( Please provide help.
0 votes
answered Dec 3, 2018 by backwater (140 points)
November 30,2018. I had a similar experience.  The firewire connection from the PC to RM32AI quit working just before a gig and just after the most recent updates.  When this connection crashed, it knocked out the wireless Ipad UC surface connections as well.  After disconnecting the firewire connection and re-booting, the wireless UC surface controls on Ipad worked but I no longer can connect via firewire.  No Capture of the gig and no backup UC surface with direct wired connection.  I tried reinstalling all the apps and updating the driver for Startech 1394b Firewire Card. This setup has worked well for 2 years.
0 votes
answered Dec 3, 2018 by vwodwo22 (140 points)
Same thing happened to us on December 01, 2018. Fortunately it was just practice.  We updated to newest firmware and software.  We are running Ableton live for backing tracks and clicks over FireWire.  On UC surface, sometimes the metering would show (sometimes).  There was always a lag when moving the faders on the mac connected with FireWire. Often moving the faders on the UC Surface (mac) would not change the volumes.  Had to power cycle the mixer several times and had to reset drivers in Ableton after every reset.  Constantly lost connection with Ipads.  And all of this is without even trying to record a show. Such a pain in the butt.

So Options:

Dante route? $600 for Dante options card? Not happening. Not gonna throw even more money into something we invested in as a work around for something it should already be able to do.

Other Audio Equipment that takes the signal from the mac so we can route to the analog xlr? $600 +/-.  Not happening.

No backing tracks, synced lights, or click (aka change whole show)? May be the only option

Run 2 computers, one hosting Ableton, the other just running UC surface? if this will even work!?!?

Attempt to rollback firmware and software? Firmware ok.  Unfortunately at the moment can only find UC surface2.9 *** on the site.  Many say 1.8 - 2.0 is where it started.

Look for another mixer? Maybe.

Spend several hours this weekend for a workaround.  That is a given :(
+1 vote
answered Dec 5, 2018 by renekrol (260 points)

My problem has been solved (with much help from a Presonus technician). I just loaded the previous version 9244 of the firmware on the RM32AI and the system didn't freeze anymore, the CS18AI kept working and the recording via the by firewire connected MacBook with Capture2 went OK. I've got a problem with strange behaviour of channels due to an backupped scene witch had been changed while the latest version of the firmware was installed on the RM32AI and recalled under the 9544 firmware version. I deleted the specific scene  and build it from scratch based on the "Zero out board" scene. All problems are gone ;-)

My current installed firmware & software versions

StudioLive CS18AI Firmware v13840 
StudioLive RM32AI Firmware v9544 
Capture 2 v2.4.0.49805 
Universal Control 2.9.2 
Apple MacOS version Mojave 10.14.1

0 votes
answered Dec 10, 2018 by darbyhughes (220 points)
Having the same issue, multiple drop-outs within a single church service... extremely embarrassing and inexcusable. We've had this issue off and on since we got the system despite multiple firmware updates, AVB updates, etc, etc, etc!

Looking into renting a reliable mixer for next week...
0 votes
answered Jul 22, 2019 by richardclay (170 points)
Has anyone figured out this problem? I just had it happen a couple weeks ago (June 2019) after I updated to latest FW and UC. I'm hoping that new firmware will fix the problem and that they are working on it. Totally unreliable now.
0 votes
answered Jul 23, 2019 by wahlerstudios (105,310 points)
You need to go back to firmware v9244 and a 2.x version of UC Surface.
0 votes
answered Feb 9, 2020 by kalebknutson (150 points)
Alright, so this just happened to me today, Feburary 9/2020, anyone have a fix or what firmware should I be running. Please this really sucked. I am the head tech at my church and it drive me nuts. We had to restart the bored, DURING service, and it took a good minute
Any help is appreciated

Studio live rm32 AI
We run with
iPad over wifi
PC over FireWire with capture
PC over ethernet for mixing live
Occasionally extra iPad