Questions & Answers

How to fix the issue of midi events happening earlier than they are being played

0 votes
93 views
asked Aug 15, 2018 in Studio One 4 by danielcady (180 points)
Whenever I record Midi in Studio one 3 Professional, no matter what midi device I use, the midi events are inserted before I play them. I have tested this with just a metronome in the DAW, recording one note on each beat, trying as hard as possible to hit on the beat. While recording everything sounds fine and perfectly in time. But when I playback the recording, each beat is almost a 16th note ahead of where it was played i.e. the 2nd note landing just at the end of the first beat instead of landing at the start of the 2nd beat. I am using the Audio Box I2 and have changed the internal block size to edit the buffer time but this has not rectified the problem. The only time I can get midi information to be in time with the song is to play very lazily behind the beat, which is impossible to maintain while trying to live record a section. Some help here would be much appreciated. Thanks

2 Answers

0 votes
answered Aug 16, 2018 by Bbd (6,730 points)

Check your MIDI Record Offset setting. 

From Help/Advanced Options/MIDI:

  • Record Offset allows you to input a value, in milliseconds, by which any recorded musical performance should be offset in the arrangement, thereby compensating for device/driver latency.
See this post:
0 votes
answered Feb 2 by laurieharrison (140 points)
I have the same issue - the notes are coming in at about 250ms early for me - i.e. everything sounds right while I'm recording (with no noticeable latency), but when I finish recording, the midi notes are all about 250ms early. The midi offset only goes up to 100ms, so is not able to solve this problem. It's a Studio One problem, since I don't have this issue in Logic, using the same hardware (Quantum 2 interface + Korg MikroKEY Air controller)
...