Questions & Answers


+1 vote
asked Sep 1, 2018 in Mixing by vicenteinvoice (490 points)
It is annoying when you use a virtual instrument and try to put it in mute or solo on the arrangement screen or in the mixer and it is not reciprocated because it seems necessary to put both on the ground. Even if this is part of the project, please change it! Mixer and arrangement screen should respond in a consistent manner.

1 Answer

0 votes
answered Sep 7, 2018 by tomferguson1 (210 points)
This is by design. Tracks and channels are separate things when it comes to virtual instruments. Mute on the track in the arrange window stops the MIDI data whereas mute on the channel in the mixer mutes the channel. Virtual instruments can output to several channels so having a mute button on the arrange window corresponding with channels on the mixer could cause a headache.

Say you had a layered multi-output instrument with 2 patches loaded. You could have 1 MIDI track going into the instrument but outputs to 2 mixer channels. Say you wanted to mute only one of the patches, muting the MIDI track could be set by default to mute both channels, but how would it appear on the arrange window if only one of the channels were muted? Semi-muted? Two mute buttons with labels for the corresponding channels? It becomes a mess.

The relationship between channels on the mixer and tracks on the arrange page can seem counterintuitive until you know this but it does allow for lots of flexibility.

Having said this it would handy to have an option to link the mute button on the arrange page to the mute button on the mixer for instruments that aren't multi-output. Or just make single stereo instrument tracks a separate type of track to multi-output instrument tracks and have single instrument tracks behave in the same way as audio tracks.