Questions & Answers

Eris 4.5 speaker pair very quiet and don't get louder, only more distorted.

0 votes
179 views
asked Oct 30, 2018 in Sceptre, Eris, R-Series by leviboylan (170 points)
I got the pair brand new from scan almost 2 weeks ago and they were fine until today, excellent audio quality and plenty loud. Today however I noticed that even though I hadn't touched the volume dial since yesterday that it was much quieter, I turned up the volume to almost half with barely any volume increase and after the halfway it stopped getting louder altogether and just got more distorted. I double checked that all the cables were still plugged in so I unplugged everything and pluggen it all back in just in case and still no improvement.

I'm using the RCA unbalanced input with the cable that came in the box, and that's plugged straight into the speaker input in the back of my motherboard.

I forgot to turn the speakers off last night so they were on for about 11 hours and when I turned the speakers off the back of the active speaker was a bit warm and one other thing I also noticed was that the little blue LED power indicator on the front isn't working properly either (it flashes when I turn the speakers on, then goes off again and when I turn the speakers off it does the same thing).

1 Answer

0 votes
answered Oct 30, 2018 by AlexTinsley (744,420 points)
 
Best answer
You need to plug it into the Green Speaker / Headphone Out Jack on the back of your computer, not the Speaker Input.

If that does not solve your issue, then open a support request in your https://my.presonus.com account so a support tech can further assist you.
...