Questions & Answers

Midi Problem: Playback midi don't match to what I recorded

+3 votes
772 views
asked Dec 10, 2018 in Studio One 4 by alexronin (200 points)

When I record with my midi keyboard I listen exactly what I'm playing, but when I playback all notes sounds like staccato. It's not a problem of my midi keyboard because I tried to record it, with same vst in different DAWs and they work fine: the playback match exactly to what I played and recorded. It's weird beacause when I add the notes manually with my mouse they work fine. 

Thank you in advance for your help. 

8 Answers

0 votes
answered Dec 10, 2018 by jamesrutherford (390 points)
i have the same issue the midi notes are doubling and then that causes the glitches i tried to get this fixed but personus has not figured it out i just gave up............ anyway i like to spend hours going through each note and fixing it.
0 votes
answered Dec 17, 2018 by ianaeillo (530 points)
Same exact thing began happening to me today. I'm not sure what it is. On projects that have been recorded previously, there is no problem. On sessions and tracks created now and moving forward, I cannot get any playback of the recorded midi besides the initial attack.
+2 votes
answered Dec 23, 2018 by andrrippstein (4,170 points)
edited Dec 23, 2018 by andrrippstein

Make sure your MIDI controller is transmitting only one note when you press a key. Some contollers have multiple zones sending a note per zone when activated. See here http://duc.avid.com/showthread.php?s=3b7e1e7631aa8d9c0c9d89a6a5767b3d&t=197378&page=2

Make sure to not have a MIDI Loop, e.g. when connecting your MIDI controller via USB and MIDI cable at the same time.

Use the MIDI Monitor of Studio One to see whats going on.

0 votes
answered Aug 31, 2019 by xbxuulns (200 points)

Andrrippstein's answer fix this issue. Closing other 3 zones of my Studiologic SL88 Grand midi keyboard fixes this issue.

Thank you so much andrrippstein.

0 votes
answered Oct 24, 2019 by richardmusick (220 points)
Try Studio One: Options: External Devices: (Click on your device), Check Mark "Default Instrumet Input". This worked 4 me..
0 votes
answered Apr 9 by zdravkobozic (200 points)

Very simple solution. The DAW is receiving two MIDI signals at the same time.

Go to Studio One / Options / External Devices ; and Remove any doubled input device that has an identical Receive From.

0 votes
answered May 19 by vinihoffmam (140 points)
Hey guys, I'm having the exact same problem here, I'm using qwerty keyboard though, so it won't show there are two sends but I can see doubled notes when I'm fixing it. I tried adrrippsttein's fix but it doesn't work for my case. Does anybody have another option for fixing this?
0 votes
answered Aug 9 by leonidasceron (150 points)

Hello everyone,

I'm having the same issue. Currently I'm using studio one 5, which it's great! but I have the same problem. It had never happened to me before. Now I'm having a P155 yamaha which I use as a midi controller. It worked fine, but just recently when I record I would have all the notes played wrongly. However, when I play I can hear that everything is perfect. The Midi playback is the problem. I also checked the Midi controler as andrrippstein suggested and I can see that when I press one key more notes are being sent. so, what can I do? Presonus please help me. I don't want to change my DAW ='(

...