Questions & Answers

Firestudio Mobile keeps flasing red/blue after Mojave 10.14.5 update

0 votes
asked Jun 20, 2019 in FireStudio Series by diannes (120 points)
Recently got a new macbook using Mojave 10.14.5. I'm using a Firestudio Mobile Presonus, just like I did on my previous macbook (with another Mojave version as I recall, and it worked fine.)

However, I can't seem to get it to work on my new laptop; the light keeps flashing red/blue. I remember from my previous laptop I had to change some setting, somewhere, but I can't remember what it was, and after googling and reading, I'm still not any wiser.

What I did already:

- install new drivers

- trying to change 'clock source' settings in Universal Studio but it doesn't want to 'click' on it so there is not much to change...

- trying to find anything in the macbook system preferences, but it is always a bit different from the examples I find on google so I can't really follow up on the given advice.

Can anyone help me out?

2 Answers

0 votes
answered Oct 17, 2019 by twinice (140 points)
Same. First time trying to use on Mojave. No luck so far. Anyone know the solution for this?
0 votes
answered May 1, 2020 by richiestonecypher (140 points)

I have had the same issue using the Firestudio Mobile over fw to thunderbolt on a Mac Mini 2012. I connected my wall power adapter and it has been fine sense. I can live with that.