Questions & Answers

All MIDI Functions Completely Broken (v3.5.6 & others)

0 votes
26 views
asked Aug 30 in Studio One 3 by keithslagerman (280 points)
Seemingly out of nowhere, I am more or less completely unable to get USB MIDI to work in Studio One 3.  I first experienced this problem in the current version of S1 (3.5.6) and I have tried downgrading as far back as 3.3.0.  The problem remains.

I first noticed recently that my hardware synthesizers were not being reliably or accurately triggered by notes in the piano roll.  (I guess this is a known issue older versions of S1) but today my problems is that none of my hardware synths are being triggered by MIDI notes in instrument track piano rolls.  I also noticed that my Faderport 8 became unstable or completely non-functional (blank LCD screens on all channel strips etc).  Basically if it relies on MIDI, Studio One is not having it.

If I go into external devices or the MIDI monitor and "reconnect", some instruments will work for a matter of seconds or until I hit stop on the transport, but after this, everything will be broken again and my MIDI none of my midi devices will work.

To try to isolate the issue, I installed a trial of another popular DAW and everything is working flawkessly.  I've also tried removing MIDI devices from my PC one by one to see if any of the hardware synths were causing this.  I've also deleted and re-added devices in External Devices .  So far, none of these tests or steps has revealed what the problem might be.  I think the fact that all of my instruments work as expected in the other DAW would seem to indicate that Studio One 3 is the issue in this case.

I'm frankly not sure where to go from here. I've done a complete uninstall / reinstall (even in removing the Presonus entries in regedit) and that also has not helped. I've got a pretty solid PC, (Presonus Studio 68, Intel core i7 8700k, 16GB RAM, SSD, GTX 1080, and the most current version of Windows 10 1903)

Any suggestions would be greatly appreciated.

Thanks

Please log in or register to answer this question.

...