Questions & Answers

Studio 68C not working with Universal Control

+1 vote
648 views
asked Nov 22, 2019 in Computer Based Recording & Production by judeluce (160 points)
Downloaded universal control software as well as studio one to go alongside presonus 68c but with presonus 68c plugged in and universal control open, the hardware is appearing at start-up but isn't selectable even though it is saying it is connected. Have updated firmware and uninstalled/re installed UC but not working.

Please can you help.

Thanks

Jude

2 Answers

+1 vote
answered Dec 4, 2019 by vitorjoaquim1 (520 points)
selected Mar 16 by AlexTinsley
 
Best answer
Hi,
I'm had the same issue.
A new installation solved the problem. I'm not sure what happened in a different way from the first try.
On the second one, while running the installation the usb cable was connected but the power was off on the Studio 68c.
After the installation of Universal Control, powered on the S68c and restarted the computer with S68c on.
All ok after.
cheers
0 votes
answered May 20 by matthewstephens2 (140 points)

Hi,

I had the exact same issue also, 

I tried the procedure that @vitorjoaquim1 suggested - and this promptly fixed the Universal Control software recognition for my Studio68c. 

Thank You, Vitor!!!

Presonus, it will be beneficial for you as a company to address this issue with specific directions upon installing Universal Control software, to minimize user frustration/disappointment. This problem was very, very annoying!!!

...