Questions & Answers

Sustain Pedal Not Recording 2020

+2 votes
asked Jan 6, 2020 in Studio One 3 by kneticmusic (140 points)
Unable to record sustain pedal properly with studio one plugins or with third party VST's.

I have followed all previous forum posts, re turning off midi filters for MIDI controller and I have added Sustain On/Off to Midi Edit window and I'm still unable to record normally. No issues when trying same plugins in FL Studio or Ableton.

When a single track is armed and monitoring I can't record sustain at all normally.

Only workaround I found was to duplicate the track, have one track to monitor input the other to record the midi data.

I would seriously like to be able to arm and monitor/record to a single track without having to make a duplicate.

This is simple midi recording, been having this issue for months. I have reinstalled Studio One, even reinstalled Windows 10 - Still no luck.

I can't use Studio One as a DAW currently. Love the program but this is beyond frustrating and definitely why I haven't upgraded further.

Studio One

OS Name:                   Microsoft Windows 10 Home
OS Version:                10.0.18362 N/A Build 18362
System Manufacturer:       Acer
System Model:              Aspire V3-575T

Processor: Intel Core i5-6200U - 2.3ghz

RAM: 16gb

HD: Samsung 250gb SSD

SETUP: Steinberg UR22 / Nektar GX61

PLEASE HELP ASAP!!!! Thank you -

3 Answers

0 votes
answered Feb 22, 2020 by manfredprothmann (160 points)

I have the same problem with sustain pedal and Studio One 4.6.0 and Windows 10.

I also use UR22. I can see the sustain pedal in the midi monitor but it's not recorded and I can't hear it.

I never have problems with cubase and as a piano player I can not use Studio One. It's very frustrading.

Please help!

0 votes
answered Mar 9, 2020 by faragher (670 points)
New user here. Sat down for my first recording session with Studio 4.6 this morning and I'm having the same problem. What a nightmare. I just paid £££ for this and it's unusable! Tried all the unchecking boxes malarky but changes nothing.

Running on Mac OSX 10.4 / Studiologic SL73
0 votes
answered Mar 9, 2020 by faragher (670 points)
I have solved my issue with strange sustain behaviour when recording by selecting midi channel one (as opposed to all which I think is the default setting) in the Edit Device dialogue box. Hope that this helps someone!