Questions & Answers

How to solve the Sustain Pedal issue!!

+13 votes
27,111 views
asked Nov 29, 2016 in Studio One 3 by Vyero (420 points) 1 flag

In order to make the Sustain pedal work on your MIDI controller you have to do 2 things:

1.- Go to: Studio One > Preferences > External Devices
Double-Click on your MIDI device to make the Edit Device window appear. Uncheck every single box on the Filter Section. Close the Edit Device and the Preferences windows.

2.- Go to: View > MIDI Monitor
Uncheck all filters. Close the MIDI Monitor window.

Try your sustain pedal...      
                          ...You are welcome!

22 Answers

+3 votes
answered May 17, 2017 by Jamesrhone1 (200,340 points)
 
Best answer
Thank you for providing this solution.
+6 votes
answered Aug 7, 2017 by daveplumb (1,500 points)
Didn't work over here!
+1 vote
answered Sep 20, 2017 by calebcindano (160 points)
Thank you!! I'm new to S1, this solved my sustain pedal problem after much searching.
0 votes
answered Apr 5, 2019 by morganwallace (150 points)
My sustain pedal with my Midi was working fine yesterday, and now it's not registering the sustain pedal today. Had all of those boxes unchecked anyways, and followed these instructions to make sure, so not solving on my end!
0 votes
answered Jun 11, 2019 by mikehowell1 (150 points)
thanks- This worked on 4.5.1.52729 for me!
+1 vote
answered Jul 3, 2019 by dominiqueletourneau (160 points)
Hello

i 've got the same pedal sustain than before, the same keyboard

and one day after an update from studio one 3 to studio one 4

the sustain is crazy ,  it works when i play but not when i record

(try everything on external devices / midi monitor ..... blablablabla .... it steel not workin

so i'm back to LOGIC and i don't have any probleme with my sustain

what wrong with studio one ????
0 votes
answered Jul 16, 2019 by robertcorrington (830 points)
One other thing… If you’re using a Native Instruments Komplete Kontrol A-series MIDI controller, please make sure the sustain pedal’s ¼” jack is fully inserted all the way into the pedal input.

If the jack is only partially inserted, the keyboard will transmit CC 65 (Portamento) instead of CC 64 (sustain pedal).
0 votes
answered Mar 11, 2020 by michaelbarton1 (140 points)
Seriously thank you. i have spent hours on this.
0 votes
answered Jun 20, 2020 by jeffreyhowell (180 points)

This worked for me! Thank you! Actually I only had to uncheck the box for "Controllers".

0 votes
answered Jul 4, 2020 by blakesheedy (640 points)
I went into both windows and everything was already unchecked, but just by opening and closing these windows it somehow fixed my issue...thanks for that! I was about ready to return my midi controller, which wasn't the issue.
0 votes
answered Jul 4, 2020 by blakesheedy (640 points)
Ah ok this is a weird issue. MIDI Monitor was the key to trouble shooting this issue for me. Upon opening that window, you will see all the midi input (play the keys, turn the knobs etc. this panel will display in real time what functions are being activated). By using this, I realized that my sustain pedal was being unresponsive. I simply unplugged it (M Gear pedal) and plugged in another pedal (a second M Gear, so that pedal DOES work, but it might be picky), and now it works.
0 votes
answered Nov 24, 2020 by ryanpoppen1 (170 points)
The sustain pedal still doesn’t get recorded tho!!!
0 votes
answered Jan 4, 2021 by adolfoalvarezconstanzo (520 points)
Thanks a Lot. This mas driving me crazy.

Regards and happy new year.
0 votes
answered Feb 19, 2021 by warrenpassaro (140 points)
'LIKE A GLOVE'! Thank you so much! (Had to laugh too - because you're welcome meant you knew it would it work!
0 votes
answered Mar 2, 2021 by oscarsanchez9 (140 points)
I just unchecked the options on the filter and it work!!! Thank you very much!
0 votes
answered Apr 3, 2021 by pawerusak (320 points)
Hi,
It works for me, thank you for the solution ;)
0 votes
answered Oct 14, 2021 by markedwards15 (140 points)
Worked like a charm! Thanks! Wish I would have come over to ask a little sooner.
0 votes
answered Feb 18, 2022 by markluthardt (160 points)
Thanks! Should have come here first. Worked perfectly with my Korg EX as the Controller Keyboard!
0 votes
answered Feb 26, 2022 by timothyburleson1 (140 points)
What worked for me is click on midi implementation icon and turn up the expression knob.
0 votes
answered May 1, 2022 by Jadonx (230 points)
Spent two days on this and in my case found I had set it up in the External devices(the one in console at bottom left) as a controller by accident! I then had to click midi learn, right click and remove.
0 votes
answered Sep 12, 2022 by chrissugden (140 points)
Thank you so much - never had this problem before but suddenly, in the middle of a studio session, no sustain! Then I found your advice which worked perfectly - such a clear and concise remedy - excellent!
0 votes
answered Feb 25 by LeeWide (150 points)
Another reason can be that you have the pedal already as a button in "MIDI Learn".
Once you remove (or even map it to sustain) it there, it worked in my case.
...