Questions & Answers

can you send me a link to Studio One version that will work with OSX 10.9.5?

0 votes
24 views
asked Jan 9 in Studio One 4 by richardupton (120 points)
I purchased the audio box 96 because it had the studio one that was meant to work with OSX 10.9.5

after loading it needs 10.10.5

Before ordering the mac spec was 10.8 and above?

Thank you

Please log in or register to answer this question.

...