Questions & Answers

PreSonus Eris 3.5 BT: Right Speaker is not working when in Bluetooth mode, but does work in AUX and TRS.

+2 votes
1,623 views
asked Jul 15, 2020 in Sceptre, Eris, R-Series by lylevincedelacuesta (220 points)
Hello All,

As the title says, my PreSonus Eris 3.5 BT right speaker doesn't work in Bluetooth mode, but it does work with AUX and TRS. I have tried other devices and it is the same. I have also tried using other Bluetooth speaker or headset and it works just fine. I am just having the problem only with this speaker. Can anybody help? Thank you very

8 Answers

0 votes
answered Jul 15, 2020 by cdricblanqui (7,520 points)
Maybe a stupid question but ... Did you pair the speakers using the specific switch behind the main one ?

H
0 votes
answered Jul 15, 2020 by lylevincedelacuesta (220 points)

I did, cdricblanqui. It does work before, dunno what happened now.

0 votes
answered Oct 8, 2020 by john-paulmuir (140 points)
I am having exactly the same issues with my PreSonus Eris 3.5BT.

Does anyone have a solution or do they need to be replaced?

Thanks.
+1 vote
answered Nov 9, 2020 by stelianion (160 points)

i have the same problem . i hope someone from Presonus to answer cause this problem is annoying .

to solve this problem i try to change the power cable but does work. i suppose the problem come from one on this :

Protection

RF interference
Output-current limiting
Over-temperature
Turn-on/off transient
Subsonic filter
External mains fuse

 

 there are moments when i  hear a few minutes music adn after no power stay for a few seconds and the sound come back .

so WHAT WE CAN DO IN THIS SITUATION????
0 votes
answered Feb 15 by johannesfindl (160 points)
I have exactly the same issue. Please
0 votes
answered Mar 31 by lylevincedelacuesta (220 points)
I still can't believe that there's no solution reply here. It's been a year!
0 votes
answered Jul 30 by talalsaleem (210 points)
Hi,

Did you people found out the cause of the problem as I am also facing the same problem with Eris3.5.
Any suggestion or help would be great!
0 votes
answered Sep 28 by rolandfuchs (140 points)
I have the same problems...
My presonus Eris 3.5 BT have the same problem as described...
My Android 10 device can not "re"-connect to the speakers.

Its always necessary to renew the pairing... and even sometimes -my smartphone shows that the speakers are connected- when i start music on the smartphone the local speakers are used!

so i would say the Bluetooth of the speakers do not work at all.
...