Questions & Answers

Studio one 5 can't connect to Soundcloud. Stuck at Redirecting.

+7 votes
asked Aug 12, 2020 in Studio One 5 by manitsony (190 points) 1 flag
So from studio one 5 once I tried to connect with sound cloud, the browser will just stuck on "redirecting" while studio one also stuck at "waiting for soundcloud to response.

I have check soundcloud setting and studio one have access to soundcloud already.

Any fix?

12 Answers

0 votes
answered Nov 25, 2020 by mikefoshee (170 points)

same issue 

"So from studio one 5 once I tried to connect with sound cloud, the browser will just stuck on "redirecting" while studio one also stuck at "waiting for soundcloud to response."

0 votes
answered Mar 10, 2021 by johnnoizz (560 points)
I was having the same issue and the only thing that it helps me was starting Studio One normally, without administrator rights, because my Studio One starts with admin rights always (I config that way in the shorcut because some plugins needs admin rights)

Maybe Presonus can address this issue better
0 votes
answered Jun 4, 2021 by justinnimmo (140 points)
I have the same problem. Stuck at redirecting. Any answers?
+3 votes
answered Jul 30, 2021 by kevyncunningham (240 points)

Having a similar issue...getting this error:

{"code":403,"message":"Requesting non-expiring tokens is not allowed. Set scope=''.","link":"","status":"403 - Forbidden","errors":[{"error_message":"Requesting non-expiring tokens is not allowed. Set scope=''."}],"error":null}

any help?

+3 votes
answered Aug 5, 2021 by danielsanchez53 (320 points)
It's now August 5th, 2021 and I am having the same problem when trying to log into Soundcloud using Studio One Pro v.5.3. I constantly get the following error and since this seems to be an old problem, I have to ask... why hasn't it been addressed by anyone at PreSonus or fixed in the application? My ability to log-in directly to my SoundCloud page was one of the reasons I bought StudioOne Pro. We could use some advice from the folks at PreSonus on this. Thanks in advance for the help.
>>>{"code":403,"message":"Requesting non-expiring tokens is not allowed. Set scope=''.","link":"","status":"403 - Forbidden","errors":[{"error_message":"Requesting non-expiring tokens is not allowed. Set scope=''."}],"error":null}<<<

+4 votes
answered Aug 16, 2021 by williamcampbell20 (250 points)
edited Aug 16, 2021 by williamcampbell20

I figured it out!
First sign into your SoundCloud account (probably not necessary but do it anyway).

Edit the end of the url in your browser's address bar on the error page from:

To look like this below: (remove the "non-expiring" leaving "scope= ")

The clue is in the error and PreSonus should have fixed this a long time ago. 
SoundCloud, understandably, doesn't want to issue an api token that last forever... 

PreSonus, if you guys are looking for good software engineer, specializing in web API integrations, I would gladly entertain an interview . 

  "code": 403,"message": "Requesting non-expiring tokens is not allowed. Set scope=''.",
  "link": "",
  "status": "403 - Forbidden","errors": [{"error_message": 
    "Requesting non-expiring tokens is not allowed. Set scope=''."}],
  "error": null


Hope this helps!

0 votes
answered Aug 18, 2021 by billmyregaard (150 points)
Not saying williamcampbell20 is a genius, but thanks a lot, because that works!!
+1 vote
answered Aug 22, 2021 by aprillee (170 points)

Yay! Editing the end of my URL and it works. Thank you @williamcampbell20

0 votes
answered Oct 11, 2021 by jrwaltb (160 points)
This does not work for even when setting the api link to ""

It logins but I cannot play songs from my soundcloud account within studio one. Please help.
0 votes
answered Feb 6, 2022 by stevenbernstein (220 points)

I'm using Studio One 4.6 and experiencing the same issues. I built a pc and installed S1 perfectly, but SoundClouid Client was showing a error message like you guys got. I changed the ending like our guy suggested. Now, I'm able to log in, but that's it. When I try to "Connect to SoundCloud" nothing was happening. I had to go to the Credential Manager to delete the OAuth 2 and SoundCloud Client credentials, close Studio One; and, start the authorization and log in process over. (Including changing the invalid link) 

Its connected. BUTTTTT the SoundCloud Client is not fully or correctly functioning. 

If I attempt to upload, it seems everything is working fine, but then the "State" of the upload says failed. I've repeated these steps above multiple times. I've searched the web multiple times, and I refuse to code to get this thing to work.

 Any ideas on what's going wrong or if this a issue that can be fixed? Also, S1 is up to date.

**this isn't a big deal breaker at the moment,  but it would be nice to use**

0 votes
answered Sep 10, 2022 by jonathanclifton89 (140 points)
This is still a issue one year down the line, Why haven't presonus sorted this out? I pay 12 quid a month and cant even use all the features...
0 votes
answered Mar 10 by marchoffmann2 (140 points)


I had exactly the same problem. The SoundCloud page was called up, I logged in and then nothing came up except "Redirecting..." and StudioOne waited forever. Then I took a closer look at the request and saw that the redirect links to a URI SCHEME, which was not added in the registry for me - under Windows. That's why it couldn't work.

In this case, the following text should be adapted accordingly, the whole thing packed into a file with the extension ".reg" and then called up under Windows:

Windows Registry Editor Version 5.00

@="URL:StudioOne OAuth2 Protocol"
"URL Protocol"=""

@="D:\\Audio\\StudioOne6\\Studio One.exe,1"



@="\"D:\\Audio\\StudioOne6\\Studio One.exe\" \"%1\""

The only important thing here is to adjust the path to the StudioOne application accordingly. After double clicking the file, you had to confirm before continue...and that's it.

Hope this would help you 8-)