Questions & Answers

Third-party plugins Graphic issue in STUDIO ONE 5. FabFilter Pro-Q3 (and many others..)

+6 votes
556 views
asked Aug 18 in Studio One 5 by andreicolta (690 points)
edited Aug 18 by andreicolta

Hi guys, 

has anyone encountered the same problem in studio one v5 with some third-party plugins such as FabFilter Pro-Q3? 

When I insert the PRO-Q3 on a channel, the windows size is just weird. Could there be a GUI issue within the V5 of Studio One?

I tried it in S1 version 4, and it works fine. Have a look at the image, please. Has anyone found a solution to this?

By the way, the Fab Filter PRO-Q2 though, works fine. 

Also, Waves plugins present a few graphic issues as well. For instance when I insert let's say the H-Delay, sometimes the window plugin is empty (but it's there) or is glitching. I found out though that if I quickly click on the routing icon and click back to the plugin (H-Delay) I can then see the plugin. 

Of course, everything works fine in S1 V4. 

Let me know if anyone can relate to this. 

Thank you

A.

** quick update **

I am currently doing a mixing session and I keep finding graphic issues with other third party plugins as well (i.e. Melda Production). I am sure at this point I'll find other plugins on the way which graphics won't work properly. This makes it hard (or even impossible) to ask Audio Companies to update their plugins so that it will fit S1's new tech. I had to go back to S1 v4, for now, which it's a shame, because Studio One's new features in version 5 are incredibly good, and unfortunatelly I can't use them. 

A part from this issue, the new version is great!

9 Answers

+1 vote
answered Aug 18 by robertgray3 (38,130 points)
Are you using AU or VST? Fabfilter Pro Q3 is working ok on Mac, maybe it's a Windows thing.

Also, just to lend some perspective I spoke to one plugin dev and the issue wasn't "Studio one's new tech", it was that Studio one 5 is more compliant with the most current os/graphical frameworks and that particular dev hasn't updated their plugin since December. I'm not saying thats the case with Melda or whoever [Melda's working ok on Mac as well btw] but I've just been letting plugin companies know when I see stuff like this and working around it as needed, either with an old version or an alternate plugin.
0 votes
answered Aug 19 by dirkandre (150 points)
I have the same issue and I think its a shame that presonus didn't test Studio One 5 properly. Its not a secret that the Fab Filter Plugins are the go to´s for many engineers. I'm really annoyed by this because I now purchased a new DAW which I tend to really like but can't use it because one of my main Plugins aren't working on it. I hope they solve it really quickly. Right now I stay on Version 4 until they fix it.

Please let me know if you found a workaround.
0 votes
answered Aug 19 by andreicolta (690 points)
Hi @robertgray3

thank you for your answer and for sharing this information. I tried both AU, VST and VST3, but the issue is still present.

I am now wondering if this has something to do with my MacOs system, I'm still on High Sierra for different reasons. Are you on Catalina?

@dirkandre, will do.

Best,

A
0 votes
answered Aug 19 by dadasound (500 points)
Obviously this is an underlying performance issue.

My Q3 is working ( Win10 ) but I see a lot of GUI slow downs,

especially on measuring plugins with high graphic activity. ( I have a few opened all the time )

Looks like the new features in V5 cost a lot of resources / CPU ... hope this can be optimized ...

No such probs in V4.xx ...

Best,  Jan
0 votes
answered Aug 21 by robertgray3 (38,130 points)
edited Aug 21 by robertgray3

@andreicolta I'm running Mojave. I have a few instances of Pro Q3 open right now in a session and they're working fine. Maybe it's GPU related, you on a laptop? Some people are reporting they need to run eGPUs on Mac laptops now. Also High Sierra has some graphics compatibility issues with some frameworks I think. Not really sure though.

@dirkandre There's nothing unusual with having to stay on Version 4 for a bit because of a plugin compatibility issue. It has happened to me at least once in every DAW. These days companies and plugin devs just can't test every setup combination out there. Make sure to tell Support (at the plugin dev and Presonus) and not just post in a comment here. It happens sometimes with every DAW and it doesn't mean it's Presonus' fault. It may be timing related- Studio One updates to support a new version of JUCE, company PluginsXYZZ doesn't support that version of JUCE yet, boom, GUI problems.

+1 vote
answered Aug 30 by carljohanthore (160 points)
Hi!

This solved the problem for me. Disable the graphics acceleration for Fabfilter plugins. Follow the instructions from Fabfilter on the following link:

https://www.fabfilter.com/support/faq/#how-can-i-disable-graphics-acceleration-on-my-computer

/CJ
0 votes
answered Aug 31 by andreicolta (690 points)
Hi @carljohanthore,

it worked, thanks for the help.

I'll let you know in case i find a solution for the other plugins as well.

Again, thank you

Best,

A.
0 votes
answered Sep 12 by lucaspiedracueva (1,060 points)
Hello everyone.

Maybe is a high sierra problem? I'm having issues with fabfilter too but also with arturia plugs, also cant work with altiverb.

If I move to mojave maybe will work? Does anyone try this?
0 votes
answered Oct 23 by mohabmohamed (140 points)
Are you using dual graphics cards? Maybe onboard and dedicated?

Make sure you switch off the onboard and update some drivers. That worked for me, just now. I'm on Windows 10 - not sure about OS X.
...