Questions & Answers

How do I stop an event from resizing after I bounce it?

0 votes
38 views
asked Sep 4 in Studio One 5 by roberttrede (1,450 points)
edited Sep 12 by roberttrede

Hi,

I am on Studio One 5 Professional.

When I bounce an even (often which I have just edited in Melodyne), that event changes size. The event will expand both to the left and to the right. If there are other events immediately to the left or to the right of the edited event, those events on both sides will be combined with that edited event.

Likewise, if the event just edited has no other events to its immediate left or right, that even will still "expand" to the left and right. While this typically doesn't "hurt" anything, I do have to go back into the even and trip it with the Split-Tool to get it back to it's original size.

Side note: This only happens if Toggle-Snap is active just before the bounce. It does not happen if I disable Toggle-Snap just before the bounce. ("Curiouser and curiouser" cried Alice.angel)


Here is an example. In the first screenshot, you can see I have just edited an even just edited in Melodyne (as evidenced by the  horizontal lines running through it.).

Note the size of the even both before and after I bounce it. It mysteriously "stretches" to the left and right.

Post-Melodyne, pre-bounce:

This is how it looks if the Melodyne edited even is bounced (with Toggle-Snap active):

Notice the extra space that has been added on the left and right of the event. Had their been other contiguous events on either side, they would have been incorporated in the new "super sized" event.

So my question is this... "Am I doing something particularly wrong or is this this a small bug in Studio One?" ... The workaround is to always (temporarily) disable Toggle-Snap before bouncing an edited event... but I sometimes forget to do that.

I'm just curious if anyone else is seeing this behavior. Initially, I thought this was happening only with events recently edited with Melodyne but after some testing, it appears Melodyne has nothing to do with it. I see this behavior with any event I have just edited.


Thanks!

1 Answer

0 votes
answered Sep 27 by ivannikalayeu (620 points)
edited Sep 27 by ivannikalayeu
Checked this in v3.5.6 and it is the same. Don't know whether it is a bug of a feature. Glad you can turn Snap off and do bounce within existing bounds.

Checking this I noticed another thing, in v3 I can open an event in Editor (F2) even when it has Melodyne on it, but in v5 it immediately openes Melodyne instead of an Editor. Haven't found a workaround yet.
...