Questions & Answers

How do I connect my Casio PX-320 to Audiobox USB96?

0 votes
49 views
asked Jan 17 in Computer Based Recording & Production by renatojacobsen (160 points)
I have a Casio Privia PX-320 and the Audiobox USB96. The piano has both the regular midi connectors and a USB port. I was able to record directly to my Macbook Pro using the USB port and Garageband without having to do anything, but Studio One doesn't detect it when connected through the midi ports in the back and no sound comes from the studio monitors connected to it either. What am I missing? I have clicked on "External Instruments" and added a new instrument set to use the USB96, but still, nothing.

1 Answer

0 votes
answered Jan 18 by renatojacobsen (160 points)
Well, let me answer my own question: keep trying. It's the steep learning curve. Studio One has plenty of hidden features and not always everything works as should. Not all sets of instruments worked on the first try, for example -- only the first I used produced sound, then one by one they came up to life. I also had to make sure I deleted all the external instruments I had created while trying to make it work, some set to use USB96, some not. I also disconnected and swapped the midi cables, just in case they were in the wrong place. Now that midi works, I'm stuck trying to make a USB microphone (T669 from Fifine) work with Studio One. It works with the Mac, it was immediately auto-detected, it's set up to use it, but at this point it's not an option in Studio One, only the left and right default options show there. More to come on this...
...