Questions & Answers

Disable ARM ALL on Faderport

+1 vote
asked Jul 16, 2021 in Recording by arthurzatarain (1,650 points)
The problem is that an inadvertent use of ARM ALL causes off-screen tracks to be armed, but the user doesn't realize it. Those tracks will be inadvertently overwritten.

If the shift key on the fadeport is illuminated, indicating that the "stuck" Shift is enabled even when not pressed, then pressing the ARM button actually causes an ARM ALL function to occur. This is OK if that is what the user wants, but in my case I only want to manually arm one or more tracks. I never want to arm all seen or unseen tracks in my session.

But with Shift enabled, pressing the ARM button will actually ARM ALL TRACKS that happen to be assigned to an input at that time (perhaps from an earlier recording session). If that track (or tracks) happen to be off screen (and off the faderport) then the user doesn't realize he has armed multiple tracks. Then, when a new recording occurs, all audio on the armed tracks is overwritten.

This situation is easy to demonstrate. Set up a session with multiple tracks, and assign some to any input. Then, slide a few tracks having inputs to off-screen in the mixer view. Set the Faderport so the shift key is stuck "on." This is easily done on my faderport by simply pressing the Shift key with no other key. The shift is then stuck ON (which a busy user may not notice). Then, if you press the ARM button it instantly performs an ARM ALL function, thereby arming the off-screen tracks without any obvious indication to the user. If you slide the hidden tracks back into view you will see that they are armed and ready to overwrite existing audio.

One solution is to allow the user to reprogram, remove, or disable the ARM ALL function from the faderport itself, or remove / disable it from Studio One. Many users don't need to simultaneously arm all tracks that happen to be assigned to an input. For me, the ability to inadvertently arm unseen tracks and overwrite audio is a real problem that has already cost me a lot of time.

Please log in or register to answer this question.