Questions & Answers

Installing sphere, must I uninstall my 2.6 and will my 2.6 songs open in 5.5?

0 votes
261 views
asked Jan 25, 2022 in Studio One+ by kevingiffin (120 points)
I am about to sign up for Sphere. I have 2.6 installed with songs.  Can I leave my 2.6 intact? Can I open 2.6 songs in Sphere?

Thank you, to whoever is answering!

1 Answer

0 votes
answered Jan 29, 2022 by vasilykorytov (11,560 points)
2.6? seems like you didn't update for a while. =)

well, 5.5 should be able to open 2.6 files, but there was at least one incompatible change over the years (the files will open, but the result will sound a bit differently). but please note that once you save them in 5.5, you won't be able to open them in 2.6 anymore.

I'd advice to keep both 2.6 and latest S1 from Sphere, at least for a while. having different S1 versions side by side should work, but you may face problems with Melodyne: 2.x works in 2.6, but isn't supported in 5.5 and 5.x doesn't work in 2.6. and several versions of Melodyne on one computer is something not supported by Celemony.

so to sum that up: I'd advice to bounce all your Melodyne edits in 2.6 files, then install the 5.5 without uninstalling 2.6. when you'll verify, all your songs are opening correctly in 5.5, you can uninstall 2.6. if you'll face some problems with new S1 failing to open old files, it's a bug and should be reported to PreSonus.

this all said, I migrated from 3.x to 4.x and then to 5.x and never needed the old S1 version I kept just in case. straight from 2.x to 5.x might be more complicated, but frankly I'd expect that this should work.
...