Questions & Answers

Why does my midi input not automatically connect ?

0 votes
1,923 views
asked Apr 14, 2016 in Studio One 3 by Søren Bohn (200 points)
If I go in options / external devices and select "reconnect" it works, but as soon as I close and open the project again, it is not working until I make the same stunt again and that is a bit annoying and time consuming. Any idea what can be the problem. I had this problem all since V 2.5 and it is still in V3.2.

Best regards Søren

2 Answers

0 votes
answered Apr 26, 2017 by TechSupport77 (195,950 points)
 
Best answer
MIDI input should be working for you without having to reconnect each time.  One thing you will want to check is that you have set your device as a "default device" under Studio One>Options (Preferences on a Mac)>External Devices.  Just double-click the device and set it as your default instrument.  You can also open your song and go into the Inspector window to verify that you have set the correct input and not "all devices."  If you have set a default MIDI device, you shouldn't have to do this.

Should there be an issue with connectivity with your device, please make sure that it is not connected to a HUB. Especially a USB hub that is also connected to an audio interface.  You may want to try a different USB port or re-install the driver for your device.  If all else fails, you may want to contact the manufacturer of the device.

For general troubleshooting in Studio One, you can try removing your settings files and then re-configure your External Devices.  Here are instructions:

1. Go to Help>Open Settings folder.

2. Copy the contents of the folder over to a folder on your desktop.

3. Close S1 and delete the contents of the settings folder with the exception of the user.license file as well as the "Extensions" folder.

4. Open S1 and go to Studio One>Options (Preferences on a Mac) to reconfigure your settings.

5. Test to see if the problem is resolved. If it is not, please feel free to copy your settings files back over from the backup that you created in step 2.

*If you are missing presets or Sound Sets after doing this, simply double-click one of your Sound Sets under Documents>Studio One>Sound Sets.
0 votes
answered Sep 22, 2021 by antg1 (720 points)
One additional observation I wish to make after you've verified all of the Answer below is to (in this order)

1)Close Studio One and Power Off your MIDI device,

2)Reboot, then login to your OS (in my case Windows 10)

3)Power up your MIDI keyboard or other MIDI Device on at this point

4) Open Studio One which now finds your MIDI device. In my case this was an Arturia Keyboard and also PreSonus Atom. Yes, all of my Inputs were correct and the QWERTY keyboard worked fine. Studio One was not receiving any MIDI input.

For some reason in Windows 10, if the MIDI keyboard is powered "on" and then you boot your PC, Studio One doesn't make the connection. Tried this with Studio One Pro v 5.4.

All was working fine yesterday and the project was saved and reopened in yesterday's session several times without issue. Today with a fresh PC boot, this was a different story and this was the only solution that worked. I'm using a MIDIMan A & B port MIDI device which is USB'd into the Windows 10 WS.
...