Questions & Answers

Multiple Tracks Are Monitored, Set to Receive All MIDI, Sustain Pedal Is Making Poly Instrument Respond As Monophonic?

0 votes
204 views
asked Dec 11, 2023 in Studio One+ by bobjohnson19 (270 points)
I'm sure I just don't know what I'm doing.

I have Parawave Rapid and Pianoteq as2 instrument tracks, each routed to a mixer channel.  If I play my sustain pedal it affects both, as it should.  

However, if Parawave has been set to Mono/Legato, for some reason Pianoteq is also responding as if it's mono / legato in terms of the sustain pedal.   For example, if I play a low - bass note and then a higher note, pianoteq will stop sustaining the lower note.

When I test by turning Parawave Rapid so it can handle poly notes, then Pianoteq stops dropping the sustain.  

So by turning Rapid to poly this let's the sustains ring out in Pianoteq, but they should be ringing out regardless of Rapid's setting, since not only am I not aware that I've set a pass thru (serial flow) between synths - but this behavior seems literally impossible since the setting in Rapid is not creating MIDI output of it's internal, non-MIDI note offs that result from it being set to mono-legato......

What's strange is I thought for sure that these were separate tracks even if they're receiving multiple MIDI channels. So the 2 synths should only be responding as they're setup - Rapid should be able to be set to mono-legato, for stylized lead, and I should still be able to get a bass note sustain to last from Pianoteq. .

Oh my goshes, what have I done wrong?

1 Answer

0 votes
answered Dec 12, 2023 by rowanhensley (1,120 points)
I don't know the answer for sure, but I know some keyboards send patch edits as control change messages. It sounds like you have both instruments set to the same midi channel. Maybe when you change the Parawave to mono it sends a patch edit signal out on that midi channel, which is being recieved by the Pianoteq. I have very little experience with software synths, but if I had this problem with my live setup, that's where I'd start. Try setting them to different midi channels? (if they're not already)
...