Questions & Answers

FireStudio Project driver 1.74 not working with Firestudio Project interface Windows 10.

0 votes
1,923 views
asked Jul 28, 2016 in FireStudio Series by ellesavec (150 points)
edited Jul 28, 2016 by ellesavec
For some reason my Fire studio project have Never worked with any other driver aside from 1.7 which wasn't really an issue until the latest windows 10 update. 1.7 will work "fine" but once leaving Studio One my drivers will not release in the background and the interface wont work for system audio.

After coming across this issue I made sure to attempt both a firmware update and factory reset using Universal Control 1.7 neither of which did anything. I have uninstalled the drivers repeatedly and reinstalled them. nothing changed.

Eventually I tried going to version 1.7.2 which would not work at first. after several installs and restarts my firestudio project flashed red and blue for around 5 minutes then seamed to connect via the Universal Control 1.7.2. However I still faced the same issue with the drivers not releasing leaving me with no system audio.

figuring the luck i had, finally being able to use 1.7.2 after some odd flashing business. I decided to give it a try with version 1.7.4. however my FireStudio Project is still unable to use Universal control 1.7.4

1 Answer

+1 vote
answered Oct 5, 2016 by butchrichard (131,090 points)
selected Oct 12, 2016 by AlexTinsley
 
Best answer
If you can achieve a solid blue sync light with any previous version of the drivers then it should work with UC 1.7.4

Use this article to fully remove all traces of previously installed versions.  

http://support.presonus.com/hc/en-us/articles/210045133-FireStudio-Family-How-do-I-Uninstall-Reinstall-my-FireStudio-drivers-in-Microsoft-Windows-

Download and install UC 1.7.4

https://pae-web.presonusmusic.com/downloads/products/zip/PreSonus_Universal_Control_174.zip

Once installed and your FireStudio connected and powered on, go to Device Manager.  You might see a FireStudio with an exclamation.  Right click and Update Driver Software.  Search Manually and click the Browse button.  Navigate to C:/ Program Files / PreSonus / Universal Control .  Click Next and OK.  

FireStudio should now achieve sync.

Open Universal Control and click Settings menu on smaller window.  Check Firmware and Factory Reset.
...