Questions & Answers

I can't update firmware on 32ai mixer after following instructions to the "T", keep getting Unknown error.

0 votes
113 views
asked Aug 9, 2016 in Ai Mixers by Toupe (180 points)
I have downloaded the firmware update 3442a1_9194 on to a Sandisk USB drive. I tried it several times to make sure I did it properly. I keep getting the same error message from the mixer. I even tried a different thumb drive. Can you help?

I'm using a Mac Mini with OSX version 10.8.5

1 Answer

0 votes
answered Aug 10, 2016 by Michael Martin (85,790 points)

Make sure the files were extracted from the ZIP file you downloaded.  The firmware files need to be on the ROOT directory of the drive in order to be seen and loaded by the process.

For OSX 10.11 users, make sure you have selected the right USB drive Icon and selected the Master Boot selection from the options, and (for all OSX versions) be sure to select FAT, FAT16, or FAT32 format.

You can try a new or different Flash drive.

See this Knowledge base article as well:
http://support.presonus.com/hc/en-us/articles/210048183-Why-isn-t-the-Firmware-Update-or-Firmware-Recovery-working-for-my-StudioLive-AI-Mixer-

If you're still having issues with the process, please submit a Support Ticket from your PreSonus account so that one of our Agents can assist you directly.

...