Questions & Answers

StudioLive 24.4.2 does not reboot past:- "LOADING PLEASE WAIT" immediately following the download of the latest Firmware

0 votes
760 views
asked Feb 29, 2016 in Ai Mixers by kaygeeeff (120 points)
As indicated by the Subject, my StudioLive 24.4.2 does not reboot past:- "LOADING PLEASE WAIT" immediately following the download of the latest Firmware update. (By direct Wireless)
StudioLive indicated a finished download and instructed a power recycle but did not Load.
Let it run like that for 30 mins. Switched off and removed the Power Lead and left it for an hour.
Plugged in and switch on but same (non) result.
What needs to be done to re-instate my StudioLive and get my Studio back in action?
All suggestions/instruction will be most gratefully welcomed!

2 Answers

0 votes
answered Mar 1, 2016 by gadget69 (30,300 points)
Hi,

Please go to your "My Presonus" account, there hopefully you have registered your Presonus hardware and software. Click on you "my hardware" and select your mixer ...in that account you'll find the latest update update... using the "firmware recovery method" download the update, unzip the files and put them on a formatted thumb drive and follow the instructions. This is the only way you should use, to insure no artifacts are left of the old drivers. There is a video there as well detailing the process.
0 votes
answered Mar 25, 2016 by bobfarrell (200 points)
I just did the firmware update on my 16:4:2 ai last night and now I have the same issue you have. "Loading Please Wait..." is all I get. Numerous reboots, letting it run for nearly 2 hours, etc. It's a huge paperweight at this point until I find out how to fix it.
...