Questions & Answers

CPU multicore support is needed. Especially for Multi Instruments.

+874 votes
5,835 views
asked Sep 30, 2016 in Mixing by LBH (3,510 points)
Feature request.
CPU multicore support is needed. Especially for Multi Instruments.

27 Answers

+23 votes
answered Oct 1, 2016 by LBH (3,510 points)
edited Dec 16, 2016 by LBH
Perhaps i should add, that for instance one instance of MAI TAI and other quality plugins allready can max out a single core. So when multiinstruments also only use one CPU core, then we easily are in deep trouble. MAI TAI alone could use multicore support.

By a request in this thread https://forums.presonus.com/viewtopic.php?f=213&t=22791 i add this here as i could'nt edit the request, and could'nt create a new answer.:
 

The distribution to the multiple cores is not working well.
Most load is put on CPU Core 0 even when using multiinstruments, and/or when using multiple plug-ins and actualy in generel. The overall CPU efficiency in Studio One will be highly improoved if this CPU core distribution issue for multicore and hyperthreading CPU's get fixed, no matter how you use Studio One.
Please read the thread and the comments below in this request.

Feel free to describe things your self in an answer.
+54 votes
answered Nov 9, 2016 by LBH (3,510 points)
selected Nov 20, 2016 by ghasenbeck
 
Best answer
Actually it looks like it's more of a distribution of the load between CPU cores/ threads/ hyperthreads issue. The load distribution is uneven and unstable.
Especially Studio Ones Multiinstruments put most load on a single core even if there are more applications that could be distributed to other cores. This makes bad use of a CPU.
+6 votes
answered Feb 16, 2017 by williamcook1 (1,210 points)
I do know that Kontakt 5 runs terribly in Studio One compared to Cubase and Logic.  I'm assuming maybe this is the same reason?  I'm not "computery" enough to know why I have to raise my buffer to max to use Kontakt, but it's unacceptable given how decent my computer is and 32 GB of ram.
+3 votes
answered Feb 17, 2017 by LBH (3,510 points)
@Williamcook1

Yes i think it can the same issue with Kontakt. Especially if you use Kontakt as a multiinstrument using more instruments in one instance.
The problem is Studio One put all the load on a track on one CPU core as it is now. The track load need to be distributed between CPU cores to be efficient.

Presonus should at least have made it so with Studio One 3 when they introduced things like their own Multiinstruments, FX features, MAI TAI and Presence XT as major sales points.
+4 votes
answered Apr 5, 2017 by violetpow (550 points)

I agree with anybody, that S1 3.4 does not use the CPU efficient. In my case its more the balance between the CPU cores.

I'm working with a 6 core Mac Pro 2013 and for example a "only Audio Tracks" song with several plugins in different tracks uses first 1 core and if the core is maxed out, then it uses the other. But why not like in Logic or Live where the cores are spread around the tracks. In Live i know that it uses first one core per track (i.e. 4 channels for 4 cores) and afterwards more tracks will be spread the tracks to the cores on top. I wonder why S1 is so behind with its "modern codebase"

+6 votes
answered Apr 11, 2017 by matthewcasey (340 points)
I am maxing out one core with pretty lightweight projects and it is causing audio glitches.  Also, the CPU usage meter seems to display only the load on one core rather than the aggregate balanced usage of all cores.  Nothing really extensive or knowledgable to add, other than to request this be updated to a more usable configuration.
+10 votes
answered May 7, 2017 by scmrecordings (1,460 points)

First, let me say that I completely agree that the CPU efficiency in Studio One is definitely behind that of other DAWs.  Coming from Sonar and Pro Tools, I would say Sonar, at least, is 2-4 times more efficient than Studio One with large projects.  Sonar just did a huge overhaul of it's CPU efficiency and specifically it's multi core efficiency and it's just incredibly powerful now.  I see no reason why Studio One shouldn't be able to do the same.  Also, I believe Sonar has a feature that temporarily bypasses plugins automatically during playback for tracks that have no content or something like that.  Really smart way to save CPU.  So yes, PLEASE update the engine to be more CPU efficient!

All of that said, I love Studio One so much I just can't get away from it. cheeky

But I'm writing here for another reason that hopefully helps people until CPU efficiency is fixed.

I came to this thread and (the other similar feature request) when I searched CPU spikes in Studio One on Google.  I was having horrible CPU spikes that would only show up with larger projects and it was driving me insane.  I'm running an I7 6800k with 64gb of Ram, multiple SSDs, etc. and should not be having random CPU spikes.  I tried running Latency Mon, disabling all my drivers, reinstalling Studio One, killing all my processes, Disabling C states and EIST in BIOS - everything I could find.  Still, the spikes were killing my workflow and making it really hard to get stuff done.

I had read in a few places about disabling Turbo Boost in BIOS (and Turbo Boost Max) but had decided that there was no way I was going to sacrifice CPU power.  Well, it got bad enough that I decided to try it and VOILA - for the first time ever for me in Studio One - NO CPU SPIKES!

My CPU is about 10-15% higher without Turbo Boost on but finally I have rock solid consistent numbers.  If it's hovering at 35%, it will go up and down maybe 3% but that's it.  Before it would spike to 100 every second or so.  This should be considered a bug in it's own right because no user should have to go into BIOS and disable a CPU feature hat makes it run a lot faster but at least I have a fix that allows me to get work done.

Anyway, I know this was a super long post but this helped me so much and I figured it could help some of you out there as well - at least until the CPU issues with Studio One get ironed out.  Have fun!

+5 votes
answered Aug 2, 2017 by lorenzosempio (590 points)
edited Aug 2, 2017 by lorenzosempio
Totally Agree!

 

I did many tests in Studio One 3.5.1 and I came to the conclusion that Studio One DOES NOT use more CPU than other DAW's, simply it is UNABLE to use the same amount of CPU as other DAW's and to spread the calculations over multi-cores;

 

comparing to Digital Performer on the same 8 core Mac Pro :

 

I can push S1 to an activity monitor CPU usage of 350% with the cores going from 35 to 70 % each (measured with menu meters app)

 

DP can load a ton more plugins and arrive to an activity monitor CPU usage of 600% with the cores going from 71 to 85 % each

 

after that both apps give me dropouts

 

this is the only reason I'm not switching to S1 as my main daw !!!

so what's up?
+15 votes
answered Sep 11, 2017 by pauldecesare (2,560 points)
Wait, WHAT? In 2017, S1 is not true multi-core? I cant even wrap my head around that. I've been doing small piano & vocal projects so S1 has been a dream. I'm now finally going down the road of film scoring and Orchestration and have fully planned on S1 being my DAW... This is really disappointing. Here I thought my 6-core i7 and 64gb ram investment had given me a great starting environment, yet the DAW can't do it.

PreSonus: you have a huge dedicated user base. This is 2017, no multi core support is insane. Please make this #1, you really owe your fans that one.

I never understood why in polls Studio One doesn't rank higher. This amazing DAW should be blowing the competition out of the water. Now I know why. Ugh.
+2 votes
answered Sep 27, 2017 by alancloughley (1,830 points)
I've experienced the same problem with big Kontakt instrument libraries and even VST plugs on audio channels. Small projects with the CPU in windows are sitting at under 20% but maxing out the performance of a core causing sessions to be unusable. Is this fixed in 3.5? As suggested turbo off in the BIOS seems to make things a little better. It would make a huge difference if Studio One performed better with VST instruments and FX, that in combination with the new 3.5 dropout protection would be a killer combo! Awesome product in so many ways, I've been using it for a year or two now and nothing else bad to say about it, best DAW I've come across in almost every respect. Some new projects need a little more grunt though and something that works on the hardware I have so will probably end up using another DAW until this is sorted.
+1 vote
answered Dec 18, 2017 by PreAl (2,130 points)
A tip for Kontakt users. Delete any convulution reverbs from plugin presets, that kills CPU in Kontakt. Set up a bus in Studio One for reverb.
+2 votes
answered Jan 22 by simonmatele (180 points)
Wow, didn't know it was this bad.

Either Presonus release a fix for this ASAP, or I will sell my Pro license and go for a modern DAW to host my plugins.

This and the inability to sync (Ableton Link support please) to other apps and platforms.

Hello?
+1 vote
answered Jan 26 by davidbaker3 (280 points)
I do not yet run Studio One 3 on a PC and this is not the fix, but if on a PC you can try something like Process Lasso. You can assign CPU priority, memory priority and I/O priority, etc.

This isn't going to utilize cores more effectively but will allows you to give it more priority on your machine.

Also, make sure there is no power profile running that can limit access to the cores. If in doubt you can assign the number of cores during boot using msconfig->advanced->boot. To make sure the OS is hitting them all, Task Manger->Performance->right click on the CPU graph and select 'logical processors' and it should show all the cores as they run.
+3 votes
answered Feb 16 by Rico Sergeant (750 points)
+1 On this request, the one thing I find really bad on Studio One is the CPU performance generally, I have a powerful mac pro but it is still very bad compared to all the other daw's, so if this would help then it gets my vote.
+3 votes
answered Feb 27 by neiljordan1 (12,620 points)
Would definitely love to see this. Getting pretty frequent momentary CPU spikes on even simple sessions - often just when it's sitting idle!
0 votes
answered Mar 21 by alexandergleich (4,000 points)
I didn’t know it’s actually that bad ... I’ll stick with Ableton Live and DP 9 then until this and the so-so MIDI implementation are fixed. I rely heavily on Kontakt for composition and sound design.
0 votes
answered May 23 by neiljordan1 (12,620 points)
Has anyone been able to review so far and confirm if this is improved in Studio One v4?
+3 votes
answered May 24 by soupiraille (1,110 points)

Unfortunately, it seems according to tests that Studio One 4 didn't improve on the subject; v4.0 and v3.5 behave the same, which is an IMMENSE shame.

It's a load balancing issue with BUS and FX channels; load balancing with TRACKS does work. 

If you want to have more technical clues about the issue, head over to this thread I created a few months ago: https://forums.presonus.com/viewtopic.php?f=151&t=28204

+1 vote
answered May 24 by diapasonprodues (1,650 points)
edited May 24 by diapasonprodues

Copying over from another related thread. Not sure about Multi Instruments, but I achieved pretty even usage across cores with a simple change in settings.

.

.

Just built a system with a 8700k all cores running at 5GHZ but Studio One is only using 80% one thread and ~15% all other 11 threads!! Imagine the POWER it can achieve if it could use all cores equivalently!

This is still way better than my previous systems (4th gen i7). The new system runs a full session of nearly 100 tracks with full editing, mixing and mastering online, in realtime, with several pretty heavy plugins, melodyne, audio bend, and multiple virtual instruments, with barely any clicks and dropouts. But "barely" is still not enough, I want to be able to activate the Softube Tape MixFX without deactivating anything else and still hear clean playback.

[ HINT (Solution) !!! ]
Right after typing my previous, I was reading on the web about this and had an idea. To decrease the buffer size of my audio device (StudioLive 32). Because I read presonus saying multicore was improved when they introduced the Dropout Protection and Low input monitoring (v3.5) and it separates the processing in different process blocks or something like that. I previously had SLive at 2048 samples and maximum dropout protection, when getting those results I mentioned before. But noticed the processing tab in SOne Options does not enable multiple block sizes when set up like that. I thought hey let's try putting SLive at 128 samples. And voila, my thread that was previously getting 80% usage was a little lower, and all other cores were a little higher. Already no more clicks and dropouts. So I though hey maybe if I set the hardware's block size as big as I can while not disabling Dropout Protection multiple block sizes, it works even better! So now my SLive is at 1028, and SOne at maximum dropout protections says 2048 samples block size, and I can see different monitoring latencies below that. Result is now I see half the threads running higher moving all over the place within 30%~50% usage, the other half is at about 30% usage, and that thread that was previously 80% usage is most often a bit higher than the others but never over 60%.
Since I observed I start to get a few clicks&pops when the highest usage thread gets to about 80%, I can say I now have those 20% spare room to add even more before realtime playback gets glitchy. I am running that same whole huge session even with mix fx softube tape active (which is VERY HEAVY on the CPU). BEAUTIFUL! Everything is online and running in realtime with zero glitches.
SET YOUR AUDIO DEVICE BLOCK SIZE LOWER THAN 2048 AND DROPOUT PROTECTION TO MAXIMUM.
(You should see different monitoring latencies for standard and low latency in the table at Options > Audio Setup > Processing. Looks like to me that setting the device's block size to the same number as the process block size causes Studio One to not use the multicore optimization from Studio One v3.5. Maybe they could fix that to still use multiple processing blocks even when the two blocks are the same size? Or perhaps set Process Block Size to 4096? Or maybe it is just that the Audio Device's buffer is still single-core and only the "virtual" internal processing buffer has been multicore optimized? In that case, is it possible to also optimize de Audio Device's buffer so we can get multicore efficiency even when not using Dropout Protection to have a bigger processing block size than the device's?)

+2 votes
answered May 30 by brconflict (1,090 points)
Has this CPU issue been addressed in Studio One 4? Other than being able to copy a mix from song to song, CPU performance is single biggest issue I have, where CPU Core 1 is picked on more than the other cores, regardless what I do. Even disabling Hyper-threading had no impact. I have no desire to gain more features until I can work on a mix without CPU issues. I'm having to use Sonar for some songs as a result. Sorry, I don't mean to troll, I just feel this thread has been voted highly, but I don't see it addressed at all in S1 4 notes/features.
0 votes
answered Jun 1 by mathisgerard (140 points)
I have an AMD FX8350 and S1 use 60% when my task manager show me 10%. It's just unacceptable and i think that S1 3 will no longer be updated now with the version 4.

(sorry if my English is bad i'm french :) )
0 votes
answered Jun 7 by brconflict (1,090 points)

Workaround to try:

So, Waves offers the SoundGrid Impact Server (I have one of the new models on pre-order; I need the CPU). However, if you use Waves, Flux, Sonnox, and maybe one or two others' plugins, if you're only needing a few plugins to be offloaded to other CPU cores, try this:

1) Download the Waves SG Studio and Studio Rack. Install them. They're free.

2) Follow instructions for installation and deployment into your DAW as normal. The only difference is, you will use your Local CPU, not an external SG Server.

When you add the Studio Rack to your plugin Chain on a channel and then add Waves plugins to it, the Studio Rack will balance the plug-in(s) across all CPU cores you have. Unfortunately, some plugins are just simply too heavy (Waves Abbey Road Plates, or CLA Signature plugins, for example) for this, so you could only use maybe one or two of them, but others can be added pretty easily. 

0 votes
answered Jun 14 by axxessdenied (220 points)
C'mon presonus please fix this ! :(
0 votes
answered Jun 16 by bennyr1 (1,170 points)
it seem studio one synths work only with AVX support in CPU good. My old CPu i5 760 4*2.8 GHZ have no AVX, only sse. the multi instrument fifths symphonie need when press 1 key 70% CPU. when press another key fast after release, it crackle horible and cpu load get near 100%. now with the i5 8600k with 6*4.1 GHZ i can use 7 fifths symphonie tracks that all play own fifths symphnie multi instrument and never get mor than 40% CPU load even if notes are fast repeat. i test with s1 4

only problem i get is that every 5-10 sec a click happen. happen in windows audio 20 ms latency and asio soundblaster z Asio with 10 ms. asio with 20 ms work good. dropout protection minimal give best results. with other settings get cpu load 100 % and sometimes instead 1 click there happen 5 or more clicks in series until it work ok. but all in all the instruments i use in songs work good. so with fast cpu that support AVX need no multicore support
0 votes
answered Jun 18 by bennyr1 (1,170 points)
I get now with 7 fifths symphonie tracks no crackle and CPU load is around 30%. before the CPU clock down with intel speed step. which is enable by default. when set in windows prefs power plan, high performance solve the problem. i find only fast this for win 7. but is in win 10 same https://www.howtogeek.com/howto/9090/learning-windows-7-manage-power-settings/

it is amazing how fast s1 synths can be. my old pc have also crackle on high performance. so i tried it first not.
0 votes
answered Jul 1 by brconflict (1,090 points)

Something to try when plug-ins cause drop-outs due to high-CPU:

Tested in 3.5:

If your sampling rate is 96Khz, it will require more CPU for your modeled plugins, such as Waves Abbey Road Reverb Plates (up to 30% CPU). Studio One can tolerate, in some cases, a lower clock speed. If you set your external clock speed to 48Khz, and set the song itself to 48Khz, you can still playback the audio and gain more CPU for the plug-ins. When you're ready to export the mixdown, simply switch back to 96Khz, and export. I don't recommend recording at different clock speeds.
 

0 votes
answered Jul 3 by accentaudio (230 points)
Have these issues been fixed in S1 v4? It's not good business when a company completely ignores its users and doesn't even acknowledge...
...