Questions & Answers

Why is SampleOne repeating / delaying the output of MIDI notes?

+1 vote
313 views
asked Feb 3, 2017 in Studio One 3 by wes8 (680 points)
Custom Computer:

Processor: Intel i7-4790K

Memory: 2 x 8 GB Corsair Vengeance Pro (16 GB)

Motherboard: ASROCK Z97M OC Formula

Storage: Samsung 850 EVO SSD (500 GB)

Operating System: Windows 10 [64 Bit]

Audio Interface: Steinberg UR28M (with latest drivers and firmware) 1.9.9 USB, 2.1.5 Application, 2.1.1 Firmware

During playback, particularly the first time after opening a project, SampleOne MIDI notes will play double or play as if there is a delay effect on them. I have checked and the notes are not stacked, there are no following notes, and there is no Delay insert on the channel. I have Cycling enabled, and sometimes after the first Cycle the weird multiple playback of a certain MIDI note will stop. I have changed the Buffer Rate from 128  to 1024 to no avail; also, seeing that I have a multi-core i7-4790K with a base clock speed of 4.0 GHz and 16 GBs of 1866 RAM, it's very hard for me to chalk it up to my hardware not being able to handle the range of Buffer Rates. Also, the number of tracks / instruments within the project at the time can be completely random. From just starting a project with 2 tracks, to being in a middle of a project with 8 tracks, it seems happen randomly; with the Performance meter floating around 10-20% CPU usage.

It seems to mostly happen after (i.e. a MIDI sequence of Snare or KIck Drum) that are multiple 1/8 notes following one another. When those notes play, it seems to produce a weird repeat / delay of additional MIDI notes. Also, when holding down a key, to play the note in SampleOne (and it's a one shot note), the sample will seem to loop, even though loop functionality is not enabled. I'm not entirely sure how to solve this problem, seeing as I can open the exact same Song on my 2010 MacBook Pro (which is at a severe disadvantage, in terms of hardware performance, compared to my PC) and it plays fine. If anyone else has experienced this problem, or may know of anything I can do to remedy, that'd be awesome.

1 Answer

0 votes
answered Apr 7, 2017 by Jamesrhone1 (186,990 points)
 
Best answer
The reason why you may be having this issue is because you are using the sample in Polyphonic mode in Sample One. In order to stop the samples from repeating, you need to run each sample in Monophonic mode. You can do this by enabling the Monophonic button in Sample One for each sample that you want to use. It also seems that you may need help learning Sample One a little more.To assist you with this, I have taken the liberty of including a link that will walk you through the process of using Sample One.

Here are the links:

...