Questions & Answers

Faderport 8 can't update to 1.02 Firmware

+4 votes
asked Feb 22, 2017 in FaderPort 8 by quadjojo (430 points)

I connected my new Faderport 8 to my MacBook Pro, the installed firmware is 1.01.

Universal Control 2.0 tells me there is a Firmware Update 1.02, I click update and the Update transfers to the FP

(FP8 displays Packets its receiving and counting to 890 of 890 Packets, takes about 3 Minutes)

After that Universal Control displays  the Firmware Update completed and I need to turn the FP off and on again.

On the FP8 all LEDs are flashing and the display says DFU Complete, Please cycle power.

I do so, i see a brief "Preparing Flash" from 0% to 100% and the FP8 started up. But Universal Control and FP8 Setup Menu say its still v1.01??

I tried reset to factory defaults and tested all the stuff through the setup menu, everything seems to work but the firmware won't update... please help!



4 Answers

0 votes
answered Feb 23, 2017 by maxstratmann (42,690 points)
Best answer

Firmware version v1.02 is only a numerical revision for compatibility with the new Universal Control 2.0. The firmware version that is installed onto the FaderPort 8 is still v1.01 as there is no change to the firmware itself. 

Firmware version v1.02 in Universal Control is only a revision for Universal Control 2.0 compatibility and will only reinstall v1.01 on the FaderPort 8 itself. This is normal and does not have any adverse effect on your FaderPort 8.

0 votes
answered Feb 23, 2017 by malleteer (1,180 points)
I have the same problem !

Any solution ?


0 votes
answered Feb 23, 2017 by marcz (1,340 points)
me too! I'm waiting for a response from PreSonus!
0 votes
answered Feb 23, 2017 by joshellyson (160 points)

We can confirm the same issue. On OS X 10.11, attempted while the unit is any of the 3 DAW Modes with the same result. Also deleted the FP8 from the Midi Configurations as suggested in some previous commentary.