Questions & Answers

Faderport 8 Sends Mix View not working as intended in Logic X

0 votes
201 views
asked May 25, 2017 in FaderPort 8 by headphonomenon (160 points)
Using the Faderport 8 with Logic Pro X. When using Sends mode, pressing once shows the sends level in each scribble strip as intended but touching any fader causes it to go into Channel Focus mode. Any one else notice this? Logic 10.2, Yosemite, Faderport firmware 1.1

2 Answers

0 votes
answered May 26, 2017 by DominicB (10,100 points)

The Sends implementation of the FaderPort 8 has changed as of firmware version 1.1. See below for the new changes in workflow.  

Initial press of "Sends" will get you into the Sends "Mix" mode. 

  • Parameters for the first Sends bus, will map across the FaderPort 8 with one parameter shown per channel. 
  • "Prev" and "Next" buttons will page through the "Sends" parameters which are controlled via the faders. 
  • The Big knob encoder will page through "Sends" slots 1 - 8 

Second press of "Sends" will get you into the Sends "Channel" mode. 

  • The FaderPort 8 focuses on the 4 parameters of the first 2 sends. That is "Send 1" Bus, Level, Pre/Post, and On/Off and the same for "Send 2". 
  • Access the additional sends using the "Prev" and "Next" buttons to page to Sends 3 - 4, then Sends 5 - 6, and Sends 7 - 8. 

0 votes
answered May 27, 2017 by headphonomenon (160 points)
Thanks for taking the time to reply DominicB. What I was trying to say is that the functionality you describe is not how it actually works on my setup. The Channel mode seems fine but in Mix mode it shows me the track names as expected but touching any fader just changes the send 1 destination for that track. I can't access any other controls. I was just wondering if that is happening for anyone else. Thanks!
...