Questions & Answers

Why my studio one doesn't give the option to connect my m-audio key rig 49?

0 votes
asked Aug 13, 2017 in Studio One 3 by heltonpignataro (150 points)
I open the " preferences / external devices / add device / manufacture "m-audio" / device name " Key Rig 49 / midi channel "all blue" /

receive from " key rig 49" / send to "from now studio one doesn't give a chance to key rig 49" . it just have the option "none"? How to fix it? Sutio one used to work very well with my key rig 49. Please help me. Thank you

1 Answer

0 votes
answered Aug 16, 2017 by TechSupport77 (195,050 points)
Best answer

If you are running Studio One 3 on a Mac, you will want to go to Studio One>Preferences>External Devices and try adding a "New Keyboard."  You can name it whatever you would like.  If you go to the "Receive From" option, and it is coming up as "none," you will want to go into Audio MIDI Setup and verify that your computer is picking up the device.  If it is not, make sure that you have installed the latest driver if there is a driver provided by the manufacturer.  In looking at M-Audio's web site, I do not see a driver for this device.  That being said, you may want to check your cables and try using a different USB port on your machine.  The bottom line is that you want to make sure that the device is showing up in the Audio MIDI setup.  

That keyboard just appears to be a MIDI keyboard controller for input and not a synth.  This is more than likely why your "Send to" option is not available.  If you are just using the device MIDI input, you only need to set the "Receive From" port.  

Once you have the "receive from" port set, you will want to open the MIDI monitor in Studio One by clicking the icon of the 5-pin MIDI cable and verify that MIDI data is flowing into the program.  You can then set the desired MIDI device as the input for an instrument track and you should be all set.  

If you have any problems, please log into your account and go to "Support" to log a support ticket.