Questions & Answers

Best setup for Studio One v3 on Surface Pro 4 for low latency and recording guitar

0 votes
291 views
asked Aug 24, 2017 in Studio One 3 by benpatient (220 points)

I am very new to all this stuff and really struggling with getting set up to enjoy latency free playing and recording. Can anyone recommend the best setup please?

Issues

When recording guitar there is a significant lag (fraction of a second, but that is enough to make playing complex melodies with a digital delay almost impossible).

If I have a couple of decent rich pads playing then I am getting CPU overload in a most distracting manner.

These are possibly two different problems, but I'd like to solve them both ideally :)

What I have tried

  1. Installing asio4all
  2. messing about with different variants of block size, etc. I just don't really know where I am hitting setup limitations or just being incompetent.

Setup

  • Studio One Professional v3.5.1 x64
  • Surface Pro 4 i7 2.2GHz with 16GB ram running Windows 10 Pro
  • (asio4all latest version)
  • Roland UA-25EX audio interface (which I have had for years so might be out of date)
  • An electric guitar
I can provide more details if need be. I am happy to buy some more kit - would AudioBox help? - if need be.
Thanks in advance!
Ben

1 Answer

+1 vote
answered Aug 25, 2017 by brianmeisner1 (163,990 points)
 
Best answer
Hi Ben,

ASIO4all is technically not supported for use with Studio One, although we have heard of it working in some scenarios.  If you have an ASIO driver that came with your audio interface, try using that.  You want to use the lowest possible Device Block Size that does not introduce pops and clicks in your audio.  Here are some steps to set things up correctly.

1.  Try setting the Device Block Size to 128 for your audio interface.  Do this in the ASIO driver for your audio interface, prior to opening Studio One.

2.  In Studio One, go into Studio One>Options>Audio Setup and click on the "Processing" tab.  Here you can set your Dropout Protection to "Maximum" to enjoy the new zero latency monitoring that we have available in version 3.5.1.

3.  Exit out of the Audio Setup menu and open the Console in Studio One.  In the Console, click the icon of the green "Z" on the main output.  You can now arm your track and record with low latency.  

____________________________________________________________

If you are working with pads and you are dealing with high CPU usage, you may need to run with a lower sample rate or try increasing your device block size.  You may also want to see if you can set the pad to work with less polyphony. If you are using Mai Tai inside of Studio One, try setting the "Quality" setting to a lower value.  

If you run into any problems, please feel free to submit a support ticket in your my.presonus.com account.  Just click on the "Support" tab.
...