Questions & Answers

Maschine not working with Studion One 3

+1 vote
627 views
asked Sep 19, 2017 in Studio One 3 by marioreyes (160 points)
My setup:

Windows 10

Studio One 3: Ver 3.5.1 (64

Maschine Ver:2.6.8

The problem: When I try to drag and drop maschine from the instruments to create a track, the first time nothing happens, the second time studio one hangs.

I can see the dll in the plug in folder (C:\Program Files\Native Instruments\VSTPlugins 64 bit) which I have mapped in the locations of studio one.

Does anyone come across this issue? Am I doing something wrong?

Thanks for your time.

2 Answers

0 votes
answered Sep 21, 2017 by brianmeisner1 (193,380 points)
 
Best answer

Hi Mario,

I personally have set up Maschine inside of Studio One 3.5.1 on a Windows 10 machine and it should be working for you.  Here are some things to try:

1.  In Studio One, go into your External Devices list and remove your MIDI devices.  Test for the issue once more and see if you can find a device that is linked to the problem.  

2.  Uninstall the Maschine VST, manually delete the .dll file from your plug-ins directory, and re-install.

3.  Try running your song at a sample rate of 44.1 if you are not doing so already.

4.  Uninstall Studio One and re-install.  Make sure that you are NOT running Studio One as administrator.

5.  Make sure that you have installed all of your Windows updates and give your system a reboot.

6.  Try removing your settings files from Studio One.  Below are instructions:

  1. Go to Help>Open Settings folder.

  2. Copy the contents of the folder over to a folder on your desktop.

  3. Close S1 and delete the contents of the settings folder with the exception of the user.license file as well as the "Extensions" folder.

  4. Open S1 and go to Studio One>Options (Preferences on a Mac) to reconfigure your settings.

  5. Test to see if the problem is resolved. If it is not, please feel free to copy your settings files back over from the backup that you created in step 2.

*If you are missing presets or Sound Sets after doing this, simply double-click one of your Sound Sets under Documents>Studio One>Sound Sets.

If you continue to have the issue, please submit a support ticket from within your my.presonus.com account and a PreSonus Tech would be more than happy to assist.

0 votes
answered Jul 21 by roneld (140 points)
I have the exact same problem. Add an instrument track and drag the Maschine 2 instrument over. A couple of flickers and thud - nothing. Drag it again and wait forever. The only thing you can do know is use Task Manager to end the instance of Studio One. this other answer is really just a laundry list of suggestions. One thing that has worked solidly for me is to delete the "Studio One 3" located at "AppData\Roaming\Presonus". You can rename it but it's useless now anyway. Start Studio One 3 and setup your Maschine in External Devices and setup your Audio Setup as well as add the locations for VST's in the Studio One\Options.Add the instrument track and drag over Maschine 2. Mine consistently shows up. I have tried saving a copy of that folder immediately after but it won't matter. The problem seems to be that Studio One 3 loses the device and reports it as missing the next time you start it up.

Hey Presonus... What's up with that? Its a huge pain.
...