Questions & Answers

Faderport work in half

0 votes
175 views
asked Jan 18, 2018 in FaderPort Classic by alessandromurgia (150 points)
Hello

I have a problem with my faderport:
until a few weeks ago, it worked perfectly.

I tried to reconnect it today, and it's like it works in half. To be more precise:

WORKS: rewind button, fast forward, stop, play, rec (but do not light up)

DOES NOT WORK: the mute buttons, solo, rec, the fader and the pan.
I upgraded the firmware 1.38, but the problem persists.

May you help me, please?
Thank you so much for your support!


I use PRO TOOLS 10.3.10
Windows 10 64bit

2 Answers

0 votes
answered Nov 4, 2018 by chrisfoster11 (440 points)
selected Jun 12 by nickmaggio
 
Best answer
Howdy all,

I  too have been struggling with this issue as well as intermittent communication errors  with Pro Tools HD 8.1.1.  However I just got my beloved classic Fader Port working again and it seems to be stable.  What partially solved it for me was running Pro Tools in Administrator mode.  You can right click and select Run as administrator each time or change  it under the compatibility tab under its properties.   Full functionality was gained by doing this but a new issue occurred  with track selection and selecting tracks.  My mouse was selecting tracks and multiple tracks as if I was holding the shift key but I wasn't causing my FP to jump around.  Right clicking on a track would clear selection but was acting odd with no apparent fix.  Track selection of the FP was jumping all around too with the strange selection issue.  So I decided to try one last thing and I ran PT with Windows 7 compatibility mode enabled and this seemed to solve it for me as now the FP runs smooth, track selection is normal and as it should with both the FP and mouse/keyboard.

Notes:
-  I'm running Pro Tools 8.1.1 HD TDM Accel II on a Window 10 Pro x64 Intel desktop that 7 years old although a fresh install.
-  If your still having issues try changing the Synchronization and Machine Control settings in Peripheral in PT as seen in the article: https://support.presonus.com/hc/en-us/articles/210040043-FaderPort-Classic-How-do-I-set-up-my-FaderPort-Classic-in-Pro-Tools-
My settings are default to PT with "Any" selected for MTC Reader Port and nothing enabled for MIDI Machine Control (Master)

Hope this helps someone else save hours trying to keep their old FP up and running!
0 votes
answered Oct 30, 2018 by peterolson (140 points)
Did you ever figure this one out?

I am having the EXACT same issue (partial functionality of other sections, but no Fader, Pan, Mute, Solo, or Rec) with PT 10 on Windows 10

Tech support has been trying, but unable to solve it for me.
...