Questions & Answers

How to setup PreSonus Faderport (1) to Cubase LE AI Elements 9.5

0 votes
536 views
asked Mar 25, 2018 in FaderPort Classic by williamweidner (150 points)

So I've gone through quite a few steps, TO NO AVAIL

I recently purchsed Used Faderport (1) Production control Center, to use with Cubase Elements 9.5 on Windows 10.  But the DAW is NOT recognizing the device to plug in Automation.

1. Went to the site, downloaded Faderport instal setup

      a. install worked UNTIL I got an error message "RegSvr32 failed with exit code 0x3"

      b. Opened Cubase and couldn't  get it to recognize device in "Studio Setup"

2. Went back, researched, found there was a version 1.2 for firmware

       a. downloaded with instructions for holding down <rewind>, <stop> and <record> buttons on the bottom of Faderport, install showed successful.

       b. restarted computer, opened up DAW, but then whenever I play my MIDI controller, a really low note that I'm not hitting keeps playing.  Turned everything off of "All MIDI inputs" on the input of the channel, but couldn't work my keyboard correctly.

Whenever I press buttons I recieve a MIDI signal, but I am not seeing Transport controlls respond to Fader buttons or ANYTHING!  is there a step I missed?  is there a download I need in order to make the faderport compatible with Cubase elements 9.5?  

(Note: I do not use Logic, Pro Tools, or Ableton, etc.)

      

1 Answer

0 votes
answered Mar 27, 2018 by AlexTinsley (772,460 points)
 
Best answer
Windows 10 b1607 (and higher) does not allow you to manually register dll's on the command line anymore. It must be installed through a program that has been digital signed by Microsoft. We've updated the FaderPort Control installer as of last week.

We recently updated latest installer for FaderPort Control which should resolve this.

https://www.presonus.com/products/FaderPort/downloads
asked Apr 6, 2018 in FaderPort Classic by carminemastromattei (230 points) It still doesnt WOrk!
...