Questions & Answers

Disarm All on Faderport 8

+22 votes
237 views
asked Sep 5, 2018 in FaderPort Series Feature Requests by owenroberts3 (680 points)
At current, when the Shift key is illuminated on a Faderport 8, the ARM button becomes 'ARM ALL'

This can be useful if you're working with multiple mics, but causes me regular problems if you accidentally have the Shift key activated, and press ARM to arm a track.  Now every track in your project is suddenly armed and you have to go through each track individually to disarm them.  Some tracks may be hidden from your current console scenes, but they're still armed, so you have to hunt through and find them one by one to disarm them.  On a project with 100+ studio tracks, this is infuriating.  I've also had feedback problems, if mics are still plugged into channels that suddenly become unintentionally armed.

Please add a feature where a second press of the 'ARM ALL' button becomes 'DISARM ALL'.

6 Answers

0 votes
answered Jan 4 by shuffle (460 points)
selected Mar 2 by owenroberts3
 
Best answer
On my faderport 2018 on mac I found a workaround for this problem: when all tracks are armed, press the options button on the keyboard  together with the arm button on faderport.. and boom, no more armed tracks..
0 votes
answered Sep 5, 2018 by AlexTinsley (902,860 points)

Thank you for the feature request. 

If anyone else agrees or disagrees, please VOTE!

The developers pay close attention to those that are voted on the most. 

You are allowed one vote. You can change your vote later if you choose.

(Here's some helpful info on how to use the voting system)

Please vote the original question / feature request. 

Please DO NOT Vote on THIS response!

+2 votes
answered Feb 2, 2019 by owenroberts3 (680 points)
Please please fix this, it's infuriating!!!

It happens at least once per session.  If you're working fast in a creative environment with other people, sometimes you don't realise the shift key is still illuminated.

I hit ARM to disarm the track I'm on, and all of a sudden 100+ tracks are ARMED

It's absurd that you then have to find each track individually and disarm each one at a time.
0 votes
answered Feb 13, 2019 by charlescuttito (140 points)
I believe if you turn off input,  on console channel from input channels, arming corresponding channel is disabled...Bud
0 votes
answered Feb 24, 2019 by Daw Stew (4,980 points)
im with you on this. It would be logical to have Arm all also function as Disarm all, but at the moment it doesn't and its really frustrating
0 votes
answered Mar 2 by owenroberts3 (680 points)
The answer below by shuffle has solved this problem for me.  

You hold down option (on Mac) and click one of the red 'channel-armed buttons' on the screen with your mouse. That disarms all tracks.

No way to do it direct from the Faderport as far as I can tell, but at least it's possible to do.
...