Questions & Answers

I have a very high CPU usage when using Presonus ,Presence ,Acoustic Piano- Ballad setting. I am using S1 3.5.6,Why...?

0 votes
38 views
asked Sep 24 in Studio One 3 by ben-daz (150 points)
I am using the following Hardware: MAC PRO mid 2010

CPU: Intel (Hex) 6 core 3.2Ghz

Memory : 32 GB DDR3 1066 MHz

Sound interface : Focusrite Liquid Saffire 56 :(Latest drivers installed all working as it should)

I have a Roland A-30 MIDI Keyboard Controller.When Using the setting Acoustic Piano from the presence Instruments,I get a cpu usage that is very high in some cases peaking at 77%,that is using ONLY that instrument..When combining it with multi instrument tracks I get cpu spiking in the RED ,CUT OUTS, and general no go...!? .

 Activity monitor also shows very high CPU usage using some of the presence settings.?How do I rectify this.?

At the moment I am forced to use other piano sounds ,that are not sounding as good as the one I mentioned.

With a computer of these specs I cannot imagine it to lay on the processing power of this equipment.

How do I rectify this problem .

Thanks Benny

2 Answers

0 votes
answered Sep 25 by brianmeisner1 (180,390 points)
 
Best answer
With the Acoustic Piano Ballad preset, there is a lot of polyphony that consumes CPU.  You can choose "mono" instead of "poly" to resolve the issue.  

If you are working with a Focusrite interface, you may want to try setting your Dropout Protection to minimum.  This is set under Studio One>Preferences>Audio Setup>Processing.
0 votes
answered Sep 25 by robertgray3 (17,950 points)
What’s your device block size?

I’m on a 2.5ghz computer and that instrument setting is definitely CPU hungry, doesn’t work well at really low block sizes.

Also multi instruments are sadly limited to one core per multi at the moment so adding on others will fill up whatever’s allocated of one of your 3.5ghz cores pretty quickly I imagine, assuming low block size
...