Questions & Answers

Can't stream S1's audio

0 votes
535 views
asked Nov 9, 2018 in Studio One 4 by elliottsebag (6,180 points)
Greetings,

I'll try to make it simple :

I'm trying to stream while using Studio One.
I hear the audio just fine but OBS (the streaming software) doesn't receive it even when i try to switch from default source to my Mackie audio interface output.

Somehow when i play a file on my pc or when i play on youtube/soundcloud it works and OBS well receives the sound.

In Live10 it also works but only when i use the MMe/DirectX driver not the Asio one, in which case i'll still hear the sound but OBS won't recieve it anymore...

In Studio One i tried once with Windows audio driver, when i clicked on the "configure audio interface" button in the preferences, i could uncheck a "exclusive mode" box and then receive the audio in OBS... but not using my Mackie interface...

Informations :

Windows 10 64bit
Studio one pro 4
Mackie Big Knob Studio +
Streamlabs OBS

I searched around youtube, google and presonus forums but no clue, any help would be lot appreciated since i really prefer to mix within s1 than live ;)

Thanks

ps : the checkbox i'm talking about is seeable here
note that i don't use banana's mixer in between s1 & obs.

2 Answers

0 votes
answered Nov 9, 2018 by elliottsebag (6,180 points)
First Solution provided by Keith Baker (studio one facebook group) :

Physically plug the output (or a copy) of your interface to a second interface .

Then run S1 has you use to and in OBS select the input of the second interface, you should have the audio .

No latency on my side .

Second interface : NI audio 10
0 votes
answered Nov 11, 2018 by elliottsebag (6,180 points)

 UPDATE :

Solution 1 - 

- install VB audio "Voice Meter Banana" and "Virtual audio Cable" 
- in S1 set audio interface to Voicemeter AUX virtual 
- in VoiceMeter you should receive S1 sound in to one of the virtual inputs 
- map the VoiceMeter output to your interface asio driver 
- make sure virtual input is unmuted, assigned to A1 and fader up ,
- in obs select a new audio source input and select VoiceMeter output as source 

Solution 2 -

- Physically connect the/an output of your interface to a second interface's input, second interface plugged in to the streaming laptop
- In obs or voice meter select the input of the second interface as source.

Thanks you guys for the fast help and kindness

...