Questions & Answers

How do I change the license from Splice Rent-to-Own to a full professional one?

0 votes
asked Nov 24, 2018 in Studio One 4 by sagekim (170 points)
I was using Splice rent-to-own plan for my Studio One but I bought the full licence of professional on Black Friday sale. I tried to activate the new license I got but I just couldn't. I uninstalled and reinstalled Studio One and now it doesn't even open saying "invalid Splice license". It just doesn't give me any option to get out of Splice OEM and activate the new license.

Please help me asap. I use the program almost everyday.

10 Answers

0 votes
answered Nov 24, 2018 by ryanm1 (3,970 points)
You have to uninstall and remove the registry key. Try this
0 votes
answered Nov 25, 2018 by jossilva5 (140 points)
May I ask what's the difference feature wise?

+1 vote
answered Nov 27, 2018 by johannesdittmar (350 points)
i´ve got the same problem. Any news about it? You can upgrade the oem license in your sayd it worked, but it´s still showing splice oem in s1.
+4 votes
answered Nov 28, 2018 by johannesdittmar (350 points)
I found the solution!

You have to remove the splice folder.

It´s AppData/SpliceSettings

If you don´t see this folder, activate "show hidden files" in your Explorer View Settings.
+1 vote
answered Nov 28, 2018 by tommierkko (160 points)
Ok, so I am on a similiar situation but on a mac.

I bought the full license for Studio one, but now I can't even boot my studio once, because it says "Your splice license for studio one is invalid". So which files (and from where) do I have to remove in order to be able to register my full license?
0 votes
answered Dec 1, 2018 by paulkraft (370 points)
Solution for Mac users:
just delete the license file in /Library/Audio/Plug-Ins/Support/Splice/ folder.
0 votes
answered Dec 4, 2018 by sagekim (170 points)

johannesdittmar is right on. 

I have waited until my then current subscription of Splice OEM to see if it could be updated automatically - because it looked like I could update OEM key in my Presonus account - but no luck. So basically it's Splice, not Studio One. Uninstalling Studio One 'completely' didn't work.

+3 votes
answered Dec 6, 2018 by benboot (200 points)
edited Dec 6, 2018 by benboot

I  was able to find a working solution for my Mac.
These are the steps I had to take to find the hidden splice folder with the old license so I could delete it. 

  1. Search “Splice” in the applications folder, even if it’s uninstalled. 
  2. Click the + button on the right hand side of the screen next to the Save button.
  3. Under the drop down menu that appears choose “System Files” & “ Are Included”.
  4. Hidden splice folders should appear and one of them has a license folder inside it.
  5. I opened the license folder, found the studio one 4 license file and deleted it.  I was good to go after that. 
+2 votes
answered Jan 11, 2019 by karlsvegare1 (220 points)
I know this post is quite old now but I guess more people are searching for the solution to this...

My problem with deleting the splice folders was that it returns after a while and I have to delete the lic-file again. This was quite exhausting so...

On PC I did like this:

Open the C:\Users\-yourusername-\AppData\Local\SpliceSettings\license\ folder and edit the studioone4.lic file with notepad. Remove all the stuff in there and save it. Then right-click the file and check the write protect box. Done. Now you should be able to start Studio One and it doesn't care about splice. win-win.

Good luck!
0 votes
answered Mar 26 by Supercross10 (210 points)
Same exact problem here on mac