Questions & Answers

How do I use a second MIDI keyboard with Studio One?

+1 vote
857 views
asked Dec 26, 2015 in Studio One 3 by makotohiguchi1 (130 points)

I have two MIDI instruments hooked up to my 'puter. The first is my 76-key and the second is a Vestax PadOne drum pad. 

So, I'm sure there's just one, stupid thing I'm missing here, but my PadOne doesn't make Studio One do anything. My keyboard is set up as "default," and it works all the time.

When I use the pads, MIDI is clearly coming in. The MIDI indicator in the bottom left-hand side of S1 shows it coming in. S1's MIDI monitor confirms that S1 is receiving MIDI from the PadOne, notes and all. Yes, I change the little drop-down thinggie in the shared VST box to "Pad-One." But, S1 just doesn't do anything with it. It knows it's there and is receiving messages, but won't pump the note information to the track. The little "activity bar" or whatever it is to the right of the track information doesn't pulse up and down as it does with the keyboard. Even with "Pad-One" selected in the dropdown, the keyboard is the thing that's recognized.

Can someone please tell me the one dumb thing I'm not doing so that I can get this to work?

Thank you, in advance.

1 Answer

0 votes
answered Dec 26, 2015 by niles (51,660 points)
edited Dec 26, 2015 by niles

I'm not sure what you mean with "the little drop-down thinggie in the shared VST box". But I would start with disabling the "Default Instrument Input" for the 76-key. After that make sure the PadOne's Receive From (Options > External Devices > Edit... ) is set to the correct MIDI PadOne port and the right MIDI channels are selected (blue), you could select them all to be sure.

Now when you set the Instrument Track's input to All Inputs, it should work (assuming the PadOne is sending note messages and not controller messages mapped to the Control Link system).

...